Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » 1С (BAS): Украина

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119

Открыть новую тему     Написать ответ в эту тему

annapetrik

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Здесь обсуждается работа версий 1С:Предприятие/Бухгалтерия/BAF (BAS) для Украины.
 
Как настроить украинский или русский язык интерфейса программы 1С / BAS Бухгалтерія - подробнее

Всего записей: 5 | Зарегистр. 07-05-2008 | Отправлено: 17:41 03-06-2008 | Исправлено: Vlood, 11:59 15-04-2021
CobraS



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
BUH404

Цитата:
А расценки можно глянуть?

Ответил в личку.

Всего записей: 294 | Зарегистр. 13-04-2009 | Отправлено: 15:54 22-02-2016
Edward Mexedov



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Nella
 

Цитата:
И как ее установить простите?  

 
Скачать, создать пустую базу, выполнить загрузку конфигурации из Конфигуратора.

Всего записей: 517 | Зарегистр. 21-12-2005 | Отправлено: 13:59 24-02-2016
patron2000

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Поделитесь пожалуйста правилами обмена данными между Бухгалтерией для Украины 1.2.34.3 и Управлением торговым предприятием для Украины 1.2.35.1. Спасибо.

Всего записей: 193 | Зарегистр. 10-09-2005 | Отправлено: 14:50 24-02-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Собственно у меня вопрос. Как сделать чтобы в расходной накладной отображались только целые числа? Например у меня есть пиво 10 бутылок в упаковке, я выбиваю накладную на три бутылки и у меня в количестве упаковок отображается 0,33333 а должно отображаться ноль. То есть если товара меньше чем на одну упаковку должно отображаться одна упаковка, если больше одной упаковки но меньше двух должна отображаться две упаковки а не 1,25 например... Куда копать?

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 17:01 26-02-2016
snfa

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
del

Всего записей: 25 | Зарегистр. 07-05-2009 | Отправлено: 17:14 26-02-2016 | Исправлено: snfa, 23:03 26-02-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Встречный вопрос, а как быть с себестоимостью единицы (упак)
Так цена упаковки у нас равна нулю (включена в стоимость товара) Да и учет не особо надо - смысл в отображении в накладной...

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 22:23 26-02-2016
snfa

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Так цена упаковки у нас

Я не про цену упаковки написал, ну да ладно... Не уверен на все 100 - но на примере ТИС.
Есть товар - допустим ваше пиво - у него есть единицы измерения - базовая бутылка и дальше  упаковка полкт и т.д. - единицы измерения взаимосвязаны каждая с собой единицами пересчета по количеству - кроме этого есть тип цены разные для бутылки упаковки и т.д.
Если вы про этакой вариант - у вас случаем базовая единица не упаковка стоит для пива?
Добавлено:

Цитата:
количестве упаковок отображается 0,33333
В ТИС добиться такого не смог - идеи закончились - поэтому из обсуждения выпадаю...
Добавлено:
ТИС - имел в виду Торговля И Склад 7.7...
 

Всего записей: 25 | Зарегистр. 07-05-2009 | Отправлено: 22:48 26-02-2016 | Исправлено: snfa, 08:46 27-02-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Если вы про этакой вариант - у вас случаем базовая единица не упаковка стоит для пива?  
Издеваетесь? Штука конечно базовая... И что такое ТИС?

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 23:35 26-02-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
ТИС - имел в виду Торговля И Склад 7.7
Так у нас вообще 8.3 ))) И торговля для частных предпринимателей Украины базовая + в плане переход на Управление Торговлей )))

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 10:28 29-02-2016
Edward Mexedov



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Nella
 

Цитата:
 То есть если товара меньше чем на одну упаковку должно отображаться одна упаковка, если больше одной упаковки но меньше двух должна отображаться две упаковки а не 1,25 например.

 
Штатных средств не помню, я бы написал что-то вроде:
 

Код:
 
Функция ОкрБольш(ТекКвоУп)
  Перем ПечКвоУп;
 
  ПечКвоУп= ТекКвоУп - Цел(ТекКвоУп);
  Если  ПечКвоУп > 0 Тогда
    ПечКвоУп = Цел(ТекКвоУп)+1;
  Иначе
        ПечКвоУп = ТекКвоУп;
  КонецЕсли;
 
  Возврат ПечКвоУп;
КонецФункции
 

Всего записей: 517 | Зарегистр. 21-12-2005 | Отправлено: 12:17 29-02-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
И куда этот код запхнуть? Все равно куда?

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 17:52 29-02-2016
Edward Mexedov



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Nella
 

Цитата:
И куда этот код запхнуть? Все равно куда?

 
В модуль, в котором определяется значение искомого параметра. То есть передавать значение в печатную форму через указанную функцию.  
 
Пример 1:
Вася=1+2,1;  
Вася = ОкрБольш(Вася);
 
Пример 2:
Вася = ОкрБольш(1+2,1);
 
 
В итоге Вася будет равно 4.

Всего записей: 517 | Зарегистр. 21-12-2005 | Отправлено: 18:41 29-02-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Да с самим кодом то понятно... С модулем вроде тоже, а что значит передавать значение на печать через функцию - представляю себе слабо... Какой мануал порекомендуете скурить кстати? И как насчет функций Excel (вроде СУММ, СРЗНАЧ и проч.) в 1С? Поддерживается? Почему-то 1С напоминает мне продвинутую таблицу Excel...

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 21:48 29-02-2016
Edward Mexedov



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Nella
 

Цитата:
а что значит передавать значение на печать через функцию - представляю себе слабо...

 
В печатной форме есть параметр. Ему передается некое значение. Значение нужно обработать на предмет округления в большую сторону. То есть значение параметра "Вася" надо передать в печатную форму как "Вася=ОкрБольш(Вася)".
 

Цитата:
Какой мануал порекомендуете скурить кстати?  

 
Любой из книжного магазина. Радченко хорошо пишет. Можно купить версию для обучения программированию.  
 

Цитата:
И как насчет функций Excel (вроде СУММ, СРЗНАЧ и проч.) в 1С? Поддерживается?  

 
Нет. 1С не имеет никакого отношения к Excel.

Всего записей: 517 | Зарегистр. 21-12-2005 | Отправлено: 22:34 29-02-2016
ralex1986

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
есть дополнение к 1С для печати конвертов извлекая контакты из карточки клиентов???
у меня 1С Предприятие 7.7 Бухучет для Украины 7.70.310

Всего записей: 62 | Зарегистр. 16-11-2014 | Отправлено: 02:14 01-03-2016
Edward Mexedov



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ralex1986
 

Цитата:
есть дополнение к 1С для печати конвертов извлекая контакты из карточки клиентов???  

 
Думаю нет. Обработки в 6-7 строк обычно не выкладывают в качестве продукта.

Всего записей: 517 | Зарегистр. 21-12-2005 | Отправлено: 11:35 01-03-2016
ralex1986

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Edward Mexedov

Цитата:
Думаю нет.  Обработки в 6-7 строк обычно не выкладывают в качестве продукта.  

где искать тогда?

Всего записей: 62 | Зарегистр. 16-11-2014 | Отправлено: 19:20 01-03-2016
Edward Mexedov



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ralex1986
 

Цитата:
где искать тогда?  

 
В смысле? Взять и написать. Там, если без наворотов, до десятка строчек. Можете в 1С выбрать меню Файл-Новый-Таблица и набрать макет-пример своего бланка. Сохраните в MXL и выложите сюда или на почту mexedovсобакамайлру. Я запихну туда эту сложнейшую процедуру:
 

Код:
 
Процедура Печать()
  Таб=СоздатьОбъект("Таблица");
  Спр=СоздатьОбъект("Справочник.Контрагенты");
  Спр.ВыбратьЭлементы();
  Пока Спр.ПолучитьЭлемент()=1 Цикл  
      Если Спр.ЭтоГруппа()=0 Тогда
          Таб.ВывестиСекцию("Конверт");
      КонецЕсли;
  КонецЦикла;
  Таб.Показать("Конверты");
КонецПроцедуры
 

 

Всего записей: 517 | Зарегистр. 21-12-2005 | Отправлено: 20:47 01-03-2016 | Исправлено: Edward Mexedov, 20:54 01-03-2016
Nella



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Кстати Управление торговлей и Управление торговлей для Украины чем отличаются? Встроенными документами, списком банков, казначейств и прочего?

Цитата:
В печатной форме есть параметр.  
В конфигураторе -  Общий модуль - формирование печатных форм?

Всего записей: 682 | Зарегистр. 18-04-2008 | Отправлено: 15:37 02-03-2016
ralex1986

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Edward Mexedov

Цитата:
В смысле? Взять и написать. Там, если без наворотов, до десятка строчек. Можете в 1С выбрать меню Файл-Новый-Таблица и набрать макет-пример своего бланка. Сохраните в MXL и выложите сюда или на почту mexedovсобакамайлру. Я запихну туда эту сложнейшую процедуру:  

 
Ок, попробую

Всего записей: 62 | Зарегистр. 16-11-2014 | Отправлено: 23:51 02-03-2016
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119

Компьютерный форум Ru.Board » Компьютеры » Программы » 1С (BAS): Украина


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru