Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » The Bat! (часть 11)

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126

Открыть новую тему     Написать ответ в эту тему

gyra

Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Прошлые части топика
Поиск ключей в варезнике

Прежде чем спрашивать ознакомьтесь с RU-Board The Bat! FAQ
 
Как задавать вопросы в этом топике. Читать обязательно!
 
Практика показывает, что большинство вопросов повторяется, например, по заморочкам с Gmail.com и Yandex.ru. Так что, скорее всего, ваш вопрос уже задавался недавно и, возможно, на него уже дали исчерпывающий ответ
 
Если поиск не помог, то переходим к следующему этапу. КАК ЗАДАТЬ ВОПРОС И ПОЛУЧИТЬ ОТВЕТ ИНСТРУКЦИЯ


 
Страница загрузки
The Bat! 9.3.2 Christmas Edition (24.12.2020)
 
Внимание! Установку альф/бет производите на свой страх и риск. Если что не так - сами себе злобные Буратино!
Еще один источник беток TB

Антиспам-плагины:
AntispamSniper плагин - мощная защита от спама, удаляющая спам непосредственно с сервера
 
полная версия шапки

Всего записей: 7932 | Зарегистр. 18-02-2006 | Отправлено: 23:42 31-10-2017 | Исправлено: L, 15:44 05-01-2021
Sant118

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Товарищи, странная проблема с oAuth2 - обновил 9.0.х Бат Вояджер на 9.3.0.2, импортнул ящики и настройки, при запуске начал запрашивать авторизацию в Gmail, но делать это ПУСТЫМ ОКНОМ со ссылкой в заголовке. Проще говоря, внутри окна не отображается страничка с запросом, она пустая.
 
Скидываю этот же настроенный Вояджер на работу, с работы всё сразу подхватывается даже без всяких окон-запросов oAuth2 и нормально работает. Что ему не нравится дома? Айпишник белый, инет нормальный кабельный и никаких проблем не создает.
 

Всего записей: 39 | Зарегистр. 21-03-2006 | Отправлено: 20:39 29-12-2020 | Исправлено: Sant118, 20:41 29-12-2020
RetroRocket



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Sant118
По вояджеру своя тема - http://forum.ru-board.com/topic.cgi?forum=5&topic=17824&start=0
Может там быстрее подскажут.

----------
"... Зовёт, зовёт в дорогу далёкий Млечный Путь ..."

Всего записей: 2478 | Зарегистр. 02-01-2018 | Отправлено: 20:46 29-12-2020
Sant118

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
По вояджеру своя тема

Я и простой Bat той же версии пробовал, проблема аналогична.

Всего записей: 39 | Зарегистр. 21-03-2006 | Отправлено: 21:02 29-12-2020
Fil_2071



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
1. Каждый год создаю новую папку и складываю туда письма за год. Естественно, внутри нее тоже создаются папки, подпапки и т. д. Можно ли скопировать структуру папок из папки "2020" в папку "2021"?
 
2. Стоит The Bat 8.8.9 и Касперский Free. Почему-то при отключении антивируса программа перестает работать с ошибкой - Ошибка протокола TLS: Неверная запись MAC DecryptBarRecordMac.
Как отвязать программы друг от друга?

----------
От сумы, тюрьмы и больницы не зарекайся ;-)

Всего записей: 1874 | Зарегистр. 30-03-2002 | Отправлено: 15:21 31-12-2020 | Исправлено: Fil_2071, 18:52 01-01-2021
Fil_2071



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Del

----------
От сумы, тюрьмы и больницы не зарекайся ;-)

Всего записей: 1874 | Зарегистр. 30-03-2002 | Отправлено: 18:52 01-01-2021 | Исправлено: Fil_2071, 18:53 01-01-2021
alloledd

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Fil_2071
Цитата:
1. Каждый год создаю новую папку и складываю туда письма за год. Естественно, внутри нее тоже создаются папки, подпапки и т. д. Можно ли скопировать структуру папок из папки "2020" в папку "2021"?  

А раньше вы как это делали?

Всего записей: 3089 | Зарегистр. 25-10-2019 | Отправлено: 19:36 01-01-2021
Fil_2071



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
А раньше вы как это делали?

Вручную. Просто интересно - можно как-то убыстрить процесс...

----------
От сумы, тюрьмы и больницы не зарекайся ;-)

Всего записей: 1874 | Зарегистр. 30-03-2002 | Отправлено: 21:35 01-01-2021
captB0nd

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Приветствую.
Проблема так и не решена.
 
 03.01.2021, 15:58:04: IMAP  - Соединение с IMAP-сервером imap.gmail.com, порт 993
 03.01.2021, 15:58:05: IMAP  - Начинаю приветствие TLS
>03.01.2021, 15:58:06: IMAP  - Свойства сертификата: 40D8F1, алгоритм: RSA (512 бит), Действителен с: 16.12.2020 6:45:32, по: 11.12.2040 6:45:32, на хосты в кол-ве 1 шт.: invalid2.invalid.
>03.01.2021, 15:58:06: IMAP  - Владелец: "No SNI provided; please fix your client.", "invalid2.invalid".
>03.01.2021, 15:58:06: IMAP  - Этот сертификат выдан самим собой.
!03.01.2021, 15:58:06: IMAP  - Приветствие TLS не завершено. Имя сервера  ("imap.gmail.com") не соответствует сертификату.
 
Касперский полностью удален из системы, корневые сертификаты обновлены. Руками удаляю непонятные сертификаты из хранилища доверенных (invalid2.invalid) - каждый раз при попытке соединения с сервером gmail создаются заново и выдают эту ошибку. Пошла третья неделя борьбы, ТП Касперского разводит руками, ТП мыши отправляют к Касперскому. Что делать? )

Всего записей: 14 | Зарегистр. 06-03-2015 | Отправлено: 16:04 03-01-2021
Bersaglio



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
captB0nd
Как на этой системе организовано подключение к Интернету? Если через корпоративную проксю - это проблема вашего сисадмина, долбите своё руководство, чтобы его заставили работать. Или уволили.

Всего записей: 2238 | Зарегистр. 21-08-2006 | Отправлено: 16:48 03-01-2021
captB0nd

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Как на этой системе организовано подключение к Интернету?

 
Без прокси (в обход, напрямую).

Всего записей: 14 | Зарегистр. 06-03-2015 | Отправлено: 16:54 03-01-2021
RetroRocket



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
captB0nd
Поймите простую вещь - у вас некто вмешивается в защищённое соединение "TheBat - Gmail" и подменяет подлинный сертификат на поддельный.
Такая подмена даёт возможность перехватывать вашу почту посторонним лицам, поэтому The Bat вполне закономерно выдаёт предупреждение и прерывает соединение.
Зачастую подмену сертификата  делает антивирус, но это может быть и другая программа по перехвату трафика.
Или даже провайдер может подменять сертификат (МГТС такое практиковал). Кроме вас никто не знает подробностей.  
Попробуйте сделать так:
1. Скачайте программу OpenSSL (https://wiki.openssl.org/index.php/Binaries) и в каталог C:\OpenSSL распакуйте архив.
2. Откройте cmd-консоль и выполните в ней команду
Код:
c:\OpenSSL\openssl.exe s_client -connect imap.gmail.com:993
OpenSSL попробует подключиться к гуглосерверу imap-почты через 993 порт. Никаких паролей / названий / имён там вводить не нужно.
3. Выделите всю полученную распечатку в окне консоли и покажите здесь, спрятав под тег more.
Помимо прочего, в распечатке будет виден и ваш неизвестный сертификат. Возможно, коллективными усилиями его удастся идентифицировать и найти решение проблемы.
Должно получиться примерно так.
В моём примере видно, что серверу imap.gmail.com соответствует сертификат, выданный "Google LLC".
А он уже подтверждён корневым удостоверяющим центром GlobalSign. Никаких сторонних посредников в цепочке соединений нет.

----------
"... Зовёт, зовёт в дорогу далёкий Млечный Путь ..."

Всего записей: 2478 | Зарегистр. 02-01-2018 | Отправлено: 16:57 03-01-2021
captB0nd

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Выделите всю полученную распечатку в окне консоли и покажите здесь, спрятав под тег more.

 
Подробнее...
 
У меня тоже есть в хранилище сертификат от Google, но до него дело не доходит.

 
 
Добавлено:
Если есть у кого-то - можете выложить версию, предшествующую 9.3.1? Именно на 9.3.1 такая проблема началась. В архиве версий не нашел...

Всего записей: 14 | Зарегистр. 06-03-2015 | Отправлено: 17:12 03-01-2021 | Исправлено: captB0nd, 18:33 03-01-2021
RetroRocket



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
captB0nd
Действительно сертификат CN = invalid2.invalid.  
Вот нашёл описание такой же ошибки в гугловской справке к Cloud Identity - https://support.google.com/cloudidentity/answer/9190869?hl=ru
 
"... Клиент/библиотека OpenSSL не поддерживает SNI
 
Во время тестирования подключения может быть возвращен следующий результат:
 
Verify return code: 18 (self signed certificate)
 
Сервису Secure LDAP требуется клиент TLS, который поддерживает и инициирует сеансы TLS с помощью SNI. Если клиент TLS не поддерживает SNI, сервер TLS (ldap.google.com) возвращает самозаверяющий сертификат, который не пройдет проверки ЦС, чтобы указать на необходимость использования SNI.
 
Чтобы убедиться в этом, проверьте выходные данные клиента OpenSSL на наличие следующей строки в начале файла:
 
depth=0 OU = "No SNI provided; please fix your client.", CN = invalid2.invalid
 
Эта ошибка может возникать из-за того, что версия OpenSSL не поддерживает SNI или приложение использует библиотеку OpenSSL с отключенным расширением SNI ..."

 
Один-в-один ваша ситуация c распечатки. Значит, я ошибся насчёт подмены сертификата.  
Из описания следует, что это сам гугл специально возвращает такой кривой сертификат в том случае, если у клиента что-то не так с SNI.  
Пока не соображу, что тут можно сделать. Разве что действительно проверить в предыдущих версиях The Bat.

----------
"... Зовёт, зовёт в дорогу далёкий Млечный Путь ..."

Всего записей: 2478 | Зарегистр. 02-01-2018 | Отправлено: 21:08 03-01-2021
Bersaglio



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
captB0nd
А попробуйте-ка запустить выполняемый модуль почтового клиента с ключом /tls_disable_ecdhe
 
Добавлено:
RetroRocket
Гугловский imap-сервер требует поддержки SNI на стороне клиента, если рукопожатие идёт с использованием TLS 1.3
 
Добавлено:
Что-то мне подсказывает, что в The Bat! 9.3.2 нет поддержки SNI

Всего записей: 2238 | Зарегистр. 21-08-2006 | Отправлено: 22:32 03-01-2021 | Исправлено: Bersaglio, 22:34 03-01-2021
Evgeniy_Voynov



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Всем привет, давно пытаюсь решить проблему с The Bat!, но не получается, может кто подскажет.
Не работает прикрепление файлов к письму методом перетаскивания (drag and drop).
В момент перетаскивания мышиный курсор говорит недопустимое действие и прикрепление файлов возможно только через кнопку прикрепить с соответствующим поиском файла по папкам.
Версия "мышки" 9.3.2 (лицензия) 64-битная.

Всего записей: 196 | Зарегистр. 27-08-2003 | Отправлено: 03:22 05-01-2021
vvms

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Bersaglio

Цитата:
Что-то мне подсказывает, что в The Bat! 9.3.2 нет поддержки SNI

В оригинальном посте говорится, что на 9.3.1 уже такое.
Может ли тут виновата ОС? На скриншоте похоже на Win7, у меня 9.3.1 на Win10 с гуглопочтой и с POP и c IMAP работает без каких-либо настроек/ключей.

Всего записей: 50 | Зарегистр. 12-11-2006 | Отправлено: 03:40 05-01-2021 | Исправлено: vvms, 03:41 05-01-2021
RetroRocket



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Bersaglio
Цитата:
Гугловский imap-сервер требует поддержки SNI на стороне клиента, если рукопожатие идёт с использованием TLS 1.3    Добавлено:  Что-то мне подсказывает, что в The Bat! 9.3.2 нет поддержки SNI
В распечатке OpenSSL написано, что "Protocol  : TLSv1.2". Да и ритлабами заявлена поддержка SNI аж с версии 8.4 -
"Added support for TLS Server Name Indication (SNI) Extension. It is useful when multiple servers are sharing the same IP address."
https://www.ritlabs.com/en/products/thebat/revision-history/7121/
Впрочем, можно попробовать принудительно указать другую версию TLS с помощью параметра "/TLS_VERSION_RANGE:1-3".
 
vvms
Цитата:
у меня 9.3.1 на Win10 с гуглопочтой и с POP и c IMAP работает без каких-либо настроек/ключей.
Тут странность в том, что и OpenSSL c того же компьютера не подключается к imap.gmail.com, получая от гугла отлуп в виде кривого сертификата.
Судя по IP-адресу, похоже что подключение идёт из некой корпоративной сети mail.tavr.ru.
 
Evgeniy_Voynov
Цитата:
Не работает прикрепление файлов к письму методом перетаскивания (drag and drop).
Вы откуда перетаскиваете? Из Проводника, TotalCommander'a или какой-то иной программы?
Проверьте, что Bat запущен от имени того же пользователя, что и Проводник, TotalCommander & e.t.c.
Сталкивался с ситуацией, когда блокировался drag&drop между программами, запущенными под разными учётками.
Правда, там был не Bat.

----------
"... Зовёт, зовёт в дорогу далёкий Млечный Путь ..."

Всего записей: 2478 | Зарегистр. 02-01-2018 | Отправлено: 07:15 05-01-2021 | Исправлено: RetroRocket, 07:25 05-01-2021
captB0nd

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
А попробуйте-ка запустить выполняемый модуль почтового клиента с ключом /tls_disable_ecdhe

C:\MyPrograms\TheBat!\thebat64.exe /tls_disable_ecdhe /TLS_VERSION_RANGE:1-3
Не помогло

Цитата:
Может ли тут виновата ОС? На скриншоте похоже на Win7, у меня 9.3.1 на Win10 с гуглопочтой и с POP и c IMAP работает без каких-либо настроек/ключей.

Дома у меня на 10ке аналогично все работает без нареканий

Цитата:
Впрочем, можно попробовать принудительно указать другую версию TLS с помощью параметра "/TLS_VERSION_RANGE:1-3".

C:\MyPrograms\TheBat!\thebat64.exe /tls_disable_ecdhe /TLS_VERSION_RANGE:1-3
Не помогло

Цитата:
Тут странность в том, что и OpenSSL c того же компьютера не подключается к imap.gmail.com, получая от гугла отлуп в виде кривого сертификата.
Судя по IP-адресу, похоже что подключение идёт из некой корпоративной сети mail.tavr.ru.

Думал об этом. Но настройки сети не менялись, хост как ходил в обход прокси, так и ходит. Единственное что поменялось - версия мыши...

Всего записей: 14 | Зарегистр. 06-03-2015 | Отправлено: 08:40 05-01-2021 | Исправлено: captB0nd, 08:45 05-01-2021
RetroRocket



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
captB0nd
Цитата:
/TLS_VERSION_RANGE:1-3  Не помогло
Это же значение по-умолчанию, разрешающее использование TLS 1.1, 1.2 и 1.3.
А речь шла про то, чтобы исключить TLS 1.3. Оставьте только TLS 1.1 и 1.2 так - /TLS_VERSION_RANGE:1-2.
Также попробуйте переключиться на системное хранилище сертификатов вместо встроенного в Bat: меню "Свойства" - "S/MIME и TLS" - "Microsoft CryptoAPI".
 


----------
"... Зовёт, зовёт в дорогу далёкий Млечный Путь ..."

Всего записей: 2478 | Зарегистр. 02-01-2018 | Отправлено: 09:28 05-01-2021
captB0nd

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Это же значение по-умолчанию, разрешающее использование TLS 1.1, 1.2 и 1.3.
А речь шла про то, чтобы исключить TLS 1.3. Оставьте только TLS 1.1 и 1.2 так - /TLS_VERSION_RANGE:1-2.
Также попробуйте переключиться на системное хранилище сертификатов вместо встроенного в Bat: меню "Свойства" - "S/MIME и TLS" - "Microsoft CryptoAPI".

 05.01.2021, 09:32:55: IMAP  - Соединение с IMAP-сервером imap.gmail.com, порт 993
 05.01.2021, 09:32:56: IMAP  - Начинаю приветствие TLS
>05.01.2021, 09:32:56: IMAP  - Свойства сертификата: 00DC4E595FA950E85BCE3284CA3EC589B1, алгоритм: RSA (2048 бит), Действителен с: 16.12.2020 6:46:05, по: 06.12.2060 6:46:05, на хосты в кол-ве 1 шт.: invalid2.invalid.
>05.01.2021, 09:32:56: IMAP  - Владелец: "No SNI provided; please fix your client.", invalid2.invalid.
>05.01.2021, 09:32:56: IMAP  - Поставщик: "No SNI provided; please fix your client.", invalid2.invalid.
!05.01.2021, 09:32:56: IMAP  - Приветствие TLS не завершено. Имя сервера  ("imap.gmail.com") не соответствует сертификату.
 
К сожалению тоже самое. ТП мыши мне второй раз присылает файл RootCA.ABD также безрезультатно.

Всего записей: 14 | Зарегистр. 06-03-2015 | Отправлено: 09:34 05-01-2021
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126

Компьютерный форум Ru.Board » Компьютеры » Программы » The Bat! (часть 11)


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru