Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » Pale Moon (часть 3)

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157

Открыть новую тему     Написать ответ в эту тему

gyra

Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Предыдущие темы: Часть 1, Часть 2


Браузер оптимизирован для современных процессоров (оптимизирована компиляция программного кода для ЦП).
Pale Moon поддерживает все процессоры (ЦП) начиная с седьмого поколения, имеющие SSE2/SSE3, т.е. Pentium IV, Pentium-M/Celeron-M, Pentium-D/Celeron-D, AMD Opteron/Athlon64 и все современные многоядерные процессоры.
 
По данным разработчиков, Pale Moon на 22-25% быстрее, чем Firefox, но, к сожалению, нет регламентированных тестов, по которым можно было бы точно определить скорость.
 

(Начиная с версии 27 поддержка Windows XP x86/x64, Server 2003 и любых retail NT 5.x прекращена)
Однако существуют пользовательские сборки под XP на основе исходников (см. ниже).

    Преимущества:
     
  • Поддержка расширений и тем Firefox
  • Оптимизированный 100%-ный исходный код Firefox
  • Выше скорость выполнения скриптов и отображения страниц, чем у Firefox
  • Потребляет меньше памяти, чем Firefox
  • Расширенная поддержка DOM
  • В портативной сборке, в отличие от Firefox, можно одновременно запускать несколько копий программы (из разных папок)

Утилита миграции с FF на PM (Pale Moon profile migration tool): скачать
 
Ссылки:
Примечания к версии / Контрольные суммы
Pale Moon 29.x.x Eng (x86: exe / 7zip / portable) | (x64: exe / 7zip / portable)
---
Pale Moon 27.9.4 Eng (x86: exe / zip / portable) | (x64: exe / zip / portable)

Версии для MacOS
Архив старых версий Pale Moon (начиная с 28-й версии)

Windows 98 | Windows XP | Пакеты локализации / Инструкция по их установке
 
Пользовательские сборки Рale Moon
Как сделать обычный Pale Moon портативным | альтернативный способ (проще)
Перевод расширений от DmFedorov
Утилита  MozArchiver для сохранения в mht взамен неработающей на 26+ UnMHT
Disable Add-on Compatibility Checks - утилита, отменяющая проверку совместимости и позволяющая ставить запрещенные расширения на Pale Moon
Исправление невозможности запуска нескольких копий портативной версии программы (в том числе и при открытии локальных файлов)
Перечень расширений, проблемных, находящихся в работе и излечиваемых в т. ч. и Moon tester tool
MozBackup It allows you to backup and restore bookmarks, mail, contacts, history, extensions, passwords, cache etc.
Если не работает Browsec 2.0.7
Ссылка на html страничку со списком не работающих сайтов и возможным лечением. *
Pale Moon Status Bar можно убрать, удалив "Palemoon\extensions\statusbar@palemoon.org.xpi"
ссылка на архив старых расширений Mozilla (удалённых с официального сайта)  Ссылка
Способ применения:
1. Берём с сайта самый свежий по дате выпуска ca-archive.xpi, устанавливаем
2. Жмём по появившемуся справа от адресной строки значку Firefox  
3. Открывается страница расширения, ждём, пока сгенерируется база, жмём "Обновить страницу" в конце
4. Пользуемся (зеркало открывается при нажатии на значок Firefox)
Ещё классические расширения
 
  Наш опрос  

Всего записей: 7932 | Зарегистр. 18-02-2006 | Отправлено: 19:14 04-06-2020 | Исправлено: simonsat, 09:51 28-11-2021
Buratino_Karlych



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
RandyOrton
Поставьте вторую копию портативного MyPal, чтобы понять, в чём проблема.

 
Пробовал уже переустанавливать - все то же...
 

Цитата:
Buratino_Karlych
Наберите: about:config
Измените значение параметра: general.useragent.override.twitter.com
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:84.0) Gecko/20100101 Firefox/84.0

 
Ура! Вот это помогло!! Спасибище!!!
 
То есть у меня вдруг поменялся useragent? А с чем это могло быть связано?

Всего записей: 40 | Зарегистр. 12-05-2009 | Отправлено: 11:22 27-04-2021
RandyOrton



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Buratino_Karlych
В MyPal есть заранее прописанные user-agent'ы для конкретных сайтов - отличитные от дефолтного user-agent. Twitter перестал нравится user-agent от FF86, возможно, он пытался в этом случае включить какую-то функцию, пкоторая есть в версии FF 86 и которой нет в MyPal.

----------
Гомосексуальность не является психическим расстройством.

Всего записей: 3260 | Зарегистр. 21-05-2010 | Отправлено: 11:41 27-04-2021
fimber

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Что то после последних обновлений хуже стало. Например google таблицы плохо открывает, работает с ними, с сайтами со многими тоже коряво пошло...

Всего записей: 72 | Зарегистр. 26-04-2016 | Отправлено: 12:02 27-04-2021
MaksimovFilimon



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
v29.2.0 (2021-04-27)

Цитата:
This is a development and bugfix release.
Starting with this version, we will no longer be supporting unmaintained legacy Firefox extensions that are not updated for/targeting Pale Moon directly.
Please see this forum post for details.
 
Changes/fixes:
- When opening tabs from the History side bar, Pale Moon will now warn you about the action if it would result in opening many tabs at once.
- Pale Moon now offers "Open All in Tabs" on bookmark folders even if there is only one sub-item in it, for UI consistency.
- Added media format controls in the Content category of Preferences.
- Added controls for preferred color scheme. See implementation notes.
- Updated several site-specific user-agent overrides for web compatibility.
- Removed the ability to accept Firefox IDs for extension installation.
- Removed conditional Macintosh code from the application front-end.
- Updated the AV1 reference library to 2.0.
- Cleaned up more Android code from the platform.
- Updated the embedded emoji font to cater to even more race-dependent profession emoji.
- Fixed an overflow in clip paths, potentially causing them to be rendered incorrectly.
- Added CSS values smooth, high-quality and pixelated to the image-rendering keyword.
- Implemented Intl.NumberFormat.formatToParts() to allow deconstruction of localized number formats by scripts.
- Reinstated the dom.details_element.enabled preference and fixed a rendering issue with summary/details html elements.
- Fixed an issue with CSP .nonce attributes on elements.
- Security issues addressed: CVE-2021-29946 DiD and CVE-2021-23994 DiD .
- Unified XUL Platform Mozilla Security Patch Summary: 2 DiD, 14 not applicable.
 
Implementation notes:
- This version adds support for the prefers-color-scheme CSS keyword. This keyword is a media query keyword that indicates to websites whether your content styling preference is "light" or "dark". Unlike other browsers where this will be tied to your system color scheme and determined automatically (which might be a point on which you can be fingerprinted, so this would be a privacy concern), we've decided to give the user control through Preferences -> Content -> Colors where you will find a new control to indicate your user preference (it defaults to "light" for everyone). While this control also gives you the option to disable this feature and effectively not support the keyword, be aware that this might cause issues on some websites that do not provide styling for "unspecified" color scheme preferences.
In the future we may add an "automatic" option similar to other browsers in case you regularly switch your system application style from light to dark and v.v.

Всего записей: 742 | Зарегистр. 13-08-2018 | Отправлено: 15:17 27-04-2021
norton46



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подскажите рабочее VPN расширение, а то это уже не подходит для 29.2 ( https://vkomforte.github.io/ )

Всего записей: 644 | Зарегистр. 25-05-2011 | Отправлено: 15:36 27-04-2021 | Исправлено: norton46, 15:41 27-04-2021
onubis

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подскажите пож. рабочее расширение типа Speed Dial, так как перестал работать на 29.2

Всего записей: 47 | Зарегистр. 13-06-2011 | Отправлено: 16:45 27-04-2021
AudioTomCat



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
To norton46
Продублирую здесь
У меня работает с изменённым install.rdf, только что открыл ВК и Яндекс.
<em:targetApplication><!-- Pale Moon -->
   <Description>
    <em:id>{8de7fcbb-c55c-4fbe-bfc5-fc555c87dbc4}</em:id>
    <em:minVersion>28.0</em:minVersion>
    <em:maxVersion>29.*</em:maxVersion>

Всего записей: 14 | Зарегистр. 18-01-2017 | Отправлено: 17:33 27-04-2021
norton46



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AudioTomCat
Можно пожалуйста подробнее что и где менять (использую офиц портативку)
 
Через Notepad изменил и сохранил но не помогло

Всего записей: 644 | Зарегистр. 25-05-2011 | Отправлено: 18:00 27-04-2021 | Исправлено: norton46, 18:12 27-04-2021
AudioTomCat



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Открываем расширение с помощью 7-Zip, затем ПКМ на install.rdf, выбрать Редактировать, дальше найти <em:targetApplication><!-- Pale Moon --> и изменить minVersion и maxVersion. Сохранить изменения.

Всего записей: 14 | Зарегистр. 18-01-2017 | Отправлено: 18:14 27-04-2021
norton46



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AudioTomCat
Странно. Открыл через Zip а там уже всё изменено как выше указано,  
плюс там несколько раз повторяются блоки с этими параметрами :  
 
<em:targetApplication><!-- Pale Moon -->
   <Description>
    <em:id>{8de7fcbb-c55c-4fbe-bfc5-fc555c87dbc4}</em:id>
    <em:minVersion>28.0</em:minVersion>
    <em:maxVersion>29.*</em:maxVersion>
 
Может свой изменённый файл здесь добавите, попробую его.
А какие расширения установлены ? у меня без расширения foxyproxy не появляется файл install.rdf

Всего записей: 644 | Зарегистр. 25-05-2011 | Отправлено: 18:23 27-04-2021 | Исправлено: norton46, 18:32 27-04-2021
Aleksandr SHCH

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Странно. Открыл через Zip а там уже всё изменено как выше указано,  
плюс там несколько раз повторяются блоки с этими параметрами :  

norton46
У вас остались не закрытые блоки. Вот пример рабочего варианта:

Цитата:
<em:targetApplication>
      <!-- Firefox -->
      <Description>
        <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
        <em:minVersion>2.0</em:minVersion>
        <em:maxVersion>27.0a1</em:maxVersion>
      </Description>
      <!-- SeaMonkey -->
      <Description>
        <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
        <em:minVersion>2.0</em:minVersion>
        <em:maxVersion>2.70.*</em:maxVersion>
      </Description>
      <!-- Pale Moon -->
   <Description>
    <em:id>{8de7fcbb-c55c-4fbe-bfc5-fc555c87dbc4}</em:id>
    <em:minVersion>28.0</em:minVersion>
    <em:maxVersion>29.*</em:maxVersion>
      </Description>
 </em:targetApplication>

Всего записей: 1861 | Зарегистр. 02-01-2008 | Отправлено: 18:34 27-04-2021 | Исправлено: Aleksandr SHCH, 18:36 27-04-2021
OffJustOff

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Для тех кому лень ковырять install.rdf руками напоминаю:
 
1. Отключаете блоклист (Настройки -> Защита -> Уровень безопасности дополнений -> Отключен)
2. Устанавливаете Moon Tester Tool отсюда
3. Открываете управление дополнениями (about:addons)
4. Для ранее установленных и заблокированных FF расширений нажимаете на кнопку ТЕСТ рядом с описанием, сохраняете оригинал и дальше согласно мастеру установки
5. Для установки новых FF расширений нажимаете на "шестеренку" и выбираете "Протестировать дополнение из файла"
6. После того как нужные расширения пропатчены и установлены, Moon Tester Tool можно отключить и даже удалить, а также включить блоклист обратно

Всего записей: 54 | Зарегистр. 20-10-2003 | Отправлено: 18:38 27-04-2021
norton46



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Добавлено:
OffJustOff
Спасибо. Заработало

Всего записей: 644 | Зарегистр. 25-05-2011 | Отправлено: 18:39 27-04-2021 | Исправлено: norton46, 18:59 27-04-2021
Kero1



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
мунчелы походу жаждут навариться )

Всего записей: 2168 | Зарегистр. 23-08-2011 | Отправлено: 19:09 27-04-2021 | Исправлено: Kero1, 19:17 27-04-2021
fimber

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
v29.2.0 (2021-04-27)
 

После обновления половина расширений как корова языком слизала....
(Похоже на предсмертные судороги, конец мучений близок)
И конечно, OffJustOff  -отдельное спасибо за совет.

Всего записей: 72 | Зарегистр. 26-04-2016 | Отправлено: 19:28 27-04-2021 | Исправлено: fimber, 19:44 27-04-2021
za4emperm



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Последний позорно сдался.  
 
 
Добавлено:
Вопрос - как с этой стрёмной версии уйти?

Всего записей: 609 | Зарегистр. 27-07-2006 | Отправлено: 22:06 27-04-2021 | Исправлено: za4emperm, 09:19 28-04-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Вопрос - как с этой стрёмной версии уйти?

Да вопрос стоит шире, на что уйти, ибо сидел именно из-за старых аддонов на FF 52, затем долгое время на PM, все устраивало, а тут такой нежданчик:
"Начиная с Pale Moon 29.2.0, браузер больше не поддерживает устаревшие расширения Firefox".
Приплыли...
зы Кто уже делал - редактирование install.rdf ручками или посредством Moon Tester Tool реально полностью решает проблему работы старых расширений на 29.2.0? После редактирования они действительно работают без проблем на этой версии?

Всего записей: 2984 | Зарегистр. 09-12-2005 | Отправлено: 12:32 28-04-2021 | Исправлено: nauticus, 12:39 28-04-2021
Krasovskii



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
nauticus
Ну надо знать - о каких именно расширениях речь? У всех свои предпочтения. К примеру у меня все расширения как работали, так и работают. Конечно же я имею ввиду те расширения, которые я использую и считаю необходимыми для себя.

Всего записей: 1119 | Зарегистр. 27-11-2014 | Отправлено: 20:08 28-04-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Ну надо знать - о каких именно расширениях речь? У всех свои предпочтения.

Это то понятно, что у всех свой наборчик. Меня интересовало до обновления на 29.2.0 в принципе - все ли расширения оживит Moon Tester Tool или есть исключения по каким-то аддонам.  
Сегодня появилась версия и на Debian, обновился, увидел сам: у меня при обновлении отключило вот эти, 7 штук аддонов:

Буду пробовать реанимировать их посредством Moon Tester Tool, особенно FAST DIAL, если не получится, то буду откатываться на прежнюю версию. Позже отпишусь о результате эксперимента.
 
Добавлено:
Отписываюсь - все 7 аддонов, отключенных из-за несовместимости новой версией 29.2.0, были адаптированы к ней именно с помощью Moon Tester Tool.  
Совет всем: пробуйте по несколько раз, было пару раз, что Moon Tester Tool указывал, что не может изменить такой-то аддон, но после 2, а то и 3 раза он обрабатывал тем не менее это расширение и все 7 отключенных аддонов теперь активны и работоспособны.
OffJustOff, за совет.

Всего записей: 2984 | Зарегистр. 09-12-2005 | Отправлено: 21:48 28-04-2021
Krasovskii



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
nauticus
Предпочитаю ручками расширения править. Был прецендент, когда после Moon Tester Tool расширение просто перестало работать. Правда было достаточно давно, подробностей не помню. Но потом строго руки а не Moon Tester Tool. Кстати, только заметил на картинке - русик Вы поменяли или оставили предыдущий? Его ведь тоже править можно, только в данном случае незачем.

Всего записей: 1119 | Зарегистр. 27-11-2014 | Отправлено: 06:53 29-04-2021 | Исправлено: Krasovskii, 06:55 29-04-2021
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157

Компьютерный форум Ru.Board » Компьютеры » Программы » Pale Moon (часть 3)


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru

Рейтинг.ru