Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » Pale Moon (часть 3)

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171

Открыть новую тему     Написать ответ в эту тему

gyra

Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Предыдущие темы: Часть 1, Часть 2


Браузер оптимизирован для современных процессоров (оптимизирована компиляция программного кода для ЦП).
Pale Moon поддерживает все процессоры (ЦП) начиная с седьмого поколения, имеющие SSE2/SSE3, т.е. Pentium IV, Pentium-M/Celeron-M, Pentium-D/Celeron-D, AMD Opteron/Athlon64 и все современные многоядерные процессоры.
 
По данным разработчиков, Pale Moon на 22-25% быстрее, чем Firefox, но, к сожалению, нет регламентированных тестов, по которым можно было бы точно определить скорость.
 

(Начиная с версии 27 поддержка Windows XP x86/x64, Server 2003 и любых retail NT 5.x прекращена)
Однако существуют пользовательские сборки под XP на основе исходников (см. ниже).

    Преимущества:
     
  • Поддержка расширений и тем Firefox
  • Оптимизированный 100%-ный исходный код Firefox
  • Выше скорость выполнения скриптов и отображения страниц, чем у Firefox
  • Потребляет меньше памяти, чем Firefox
  • Расширенная поддержка DOM
  • В портативной сборке, в отличие от Firefox, можно одновременно запускать несколько копий программы (из разных папок)

Утилита миграции с FF на PM (Pale Moon profile migration tool): скачать
 
Ссылки:
Примечания к версии / Контрольные суммы
Pale Moon 29.x.x Eng (x86: exe / 7zip / portable) | (x64: exe / 7zip / portable)
---
Pale Moon 27.9.4 Eng (x86: exe / zip / portable) | (x64: exe / zip / portable)

Версии для MacOS
Архив старых версий Pale Moon (начиная с 28-й версии)

Windows 98 | Windows XP | Пакеты локализации / Инструкция по их установке
 
Пользовательские сборки Рale Moon
Как сделать обычный Pale Moon портативным | альтернативный способ (проще)
Перевод расширений от DmFedorov
Утилита  MozArchiver для сохранения в mht взамен неработающей на 26+ UnMHT
Disable Add-on Compatibility Checks - утилита, отменяющая проверку совместимости и позволяющая ставить запрещенные расширения на Pale Moon
Исправление невозможности запуска нескольких копий портативной версии программы (в том числе и при открытии локальных файлов)
Перечень расширений, проблемных, находящихся в работе и излечиваемых в т. ч. и Moon tester tool
MozBackup It allows you to backup and restore bookmarks, mail, contacts, history, extensions, passwords, cache etc.
Если не работает Browsec 2.0.7
Ссылка на html страничку со списком не работающих сайтов и возможным лечением. *
Pale Moon Status Bar можно убрать, удалив "Palemoon\extensions\statusbar@palemoon.org.xpi"
ссылка на архив старых расширений Mozilla (удалённых с официального сайта)  Ссылка
Способ применения:
1. Берём с сайта самый свежий по дате выпуска ca-archive.xpi, устанавливаем
2. Жмём по появившемуся справа от адресной строки значку Firefox  
3. Открывается страница расширения, ждём, пока сгенерируется база, жмём "Обновить страницу" в конце
4. Пользуемся (зеркало открывается при нажатии на значок Firefox)
Ещё классические расширения
 
  Наш опрос  

Всего записей: 7932 | Зарегистр. 18-02-2006 | Отправлено: 19:14 04-06-2020 | Исправлено: simonsat, 09:51 28-11-2021
StupidUser



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Можно ли какую-нибудь версию MyPal заставить работать с Ozon.ru? Чтобы авторизацию можно было пройти, а в идеале еще и в их чат зайти.
 
(У меня при запуске v.29.3.0 с параметрами по умолчанию при авторизации только три точки бегают, а полей с телефоном и почтой так и не появляется.)
 
Кто-нибудь знает, на какой версии Firefox основана эта версия?

Всего записей: 494 | Зарегистр. 19-04-2003 | Отправлено: 02:44 22-11-2021 | Исправлено: StupidUser, 03:06 22-11-2021
freed7



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
StupidUser
Цитата:
заставить работать с Ozon.ru?  
О, присоединяюсь к вопросу: у меня в PM 28.15.0 на озоне не работают ссылки на Отзывы (интерактивная надпись "Отзывы"): просто тупо ничего не происходит при нажатии на эти ссылки по любому товару.

Всего записей: 98 | Зарегистр. 30-10-2020 | Отправлено: 02:54 22-11-2021 | Исправлено: freed7, 00:40 23-11-2021
RandyOrton



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
StupidUser
Можно. В этой теме или теме про Basilisk обсуждались polyfill.

Цитата:
Кто-нибудь знает, на какой версии Firefox основана эта версия?

На 52.

----------
Гомосексуальность не является психическим расстройством.

Всего записей: 3425 | Зарегистр. 21-05-2010 | Отправлено: 14:50 22-11-2021
santias



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Уточните, пожалуйста, где действует дополнение "github-wc-polyfill" (только на github.com, или на каких-то ещё сайтах) ?

Всего записей: 424 | Зарегистр. 12-04-2016 | Отправлено: 05:28 23-11-2021
Grishanenko

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
За 6 лет забился WishList (избранное) на Aliexpress. 1000 штук. Причем, 50% товаров уже не доступны у продавцов.
Хотел почистить, но все оказалось значительно сложнее, чем я думал.
Выделить несколько товаров на странице и удалить невозможно. Только по одному.
Причем, после клика по ссылке "Remove" страница автоматически перезагружается.
Полумера - ПКМ, открыть в новой вкладке и через 5-10 секунд закрыть эту новую вкладку.
Но это тоже куча времени и 100% тормоза браузера.
Есть ли дополнение, которое может помочь в этом вопросе?
Т.е. условно говоря, заблокировать возможность открытия новых вкладок, по ЛКМ только послать запрос на сайт и через несколько секунд прервать его.

Всего записей: 668 | Зарегистр. 17-06-2006 | Отправлено: 11:35 23-11-2021
Enobarbous



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
StupidUser, freed7
Цитата:
Ozon.ru
Этот полифилл + юзерагент от 68го фаерфокса (не новее!). UA был где-то в теме василиска, а может и здесь пробегал. Если ни разу не ставили скрипты - где-то в теме я писал инструкцию для совсем-совсем новичков.
И не забывайте использовать поиск по теме здесь и в топике василиска - этот вопрос уже кажется четвертый раз поднимают.
 
santias
Гитхаб, гитлаб и еще несколько сайтов - со 2й по 43ю строчки
Черт возьми, люди, исходники же удобно доступны, можно же и самим глянуть...
 
Grishanenko
С дополнением сложно - вроде теоретически можно попробовать накидать кнопку для cb, но готовый вариант мне не попадался (да и акка на али для теста нет...) Можете попробовать извратится с макросом (записать движения и клики мышки "ПКМ, открыть в новой вкладке и через 10 секунд закрыть эту новую вкладку", запустить на бесконечный повтор и пойти курить) или попробуйте временно зарезать блокировщиком рекламы все изображения и лишние скрипты (их скорее всего перебором определять придется) - может перезагрузка страницы заработает быстрее...


Товарищи "свидетели ютуба", несколько моментов перед тем, как. Во-первых - всегда проверяйтесь на чистом профиле. Во-вторых - супермегасерьезной разницы в движке между PM28 и PM29 нет. 29е - это обычные релизы разработки (с не самым большим количеством изменений), которым сменили версию на старшую потому что разработчики обосрались с обещаниями (обещания теперь перенесены на 30ку). В-третьих - если кто-то по каким-либо причинам пользуется последним PM27 - используйте вместо него NewMoon 27 Build от Roytam1. Там огромное количество полезных изменений по сравнению с крайним официальным 27мым. В том числе и довольно много правок веб-совместимости. В-четвертых - есть мобильная версия и 2 маленьких, но полезных дополнения от RealityRipple'a (1, 2)
Ну и в-пятых - может хватит возмущаться тем, что "злой-подлый-гадкий-гугол" отламывает поддержку 4х- и более летних браузеров, особенно с учетом того что это можно решить одним префом? Это уже реально смешно, особенно с учетом того, что мы, как пользователи, по-сути занимаемся некрофилией со всеми этими древнефоксоклонами.
Извиняюсь, конечно, но надоело уже...

Всего записей: 166 | Зарегистр. 13-01-2020 | Отправлено: 15:16 23-11-2021 | Исправлено: Enobarbous, 19:52 23-11-2021
santias



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Enobarbous

Цитата:
Гитхаб, гитлаб и еще несколько сайтов - со 2й по 43ю строчки
Черт возьми, люди, исходники же удобно доступны, можно же и самим глянуть...

Спасибо большое за ответ. И я конечно глянул бы сам в исходники, если бы понимал, что это такое. (Ранее я имел дело с исходниками только в киноиндустрии).
Именно поэтому задаю вытекающий отсюда вопрос:
- Можно ли и как подправить в "github-wc-polyfill" файл bootstrap.js, где перечисляются указанные Вами 42 сайта, на которых действует дополнение таким образом, чтобы оно работало для всех сайтов, кроме специально оговоренных?

Всего записей: 424 | Зарегистр. 12-04-2016 | Отправлено: 21:38 23-11-2021 | Исправлено: santias, 21:44 23-11-2021
StupidUser



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Enobarbous

Цитата:
Этот полифилл + юзерагент от 68го фаерфокса (не новее!). UA был где-то в теме василиска, а может и здесь пробегал. Если ни разу не ставили скрипты - где-то в теме я писал инструкцию для совсем-совсем новичков.
И не забывайте использовать поиск по теме здесь и в топике василиска - этот вопрос уже кажется четвертый раз поднимают.
 

Использовал поиск по теме. Тема Озона действительно поднималась, но нигде не рассказано подробно, как ее решить. В основном было сказано, что Озон так и не заработает. Инструкции про скрипты для новичков не нашел, т.к. не знаю по какому контексту искать. Если Вы знаете точно, что делать, дайте, пожалуйста, ссылки на алгоритм действий с их описанием. Что такое юзерагент от 68го фаерфокса, где его взять и что с ним делать?

Всего записей: 494 | Зарегистр. 19-04-2003 | Отправлено: 22:37 23-11-2021 | Исправлено: StupidUser, 22:37 23-11-2021
Enobarbous



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
santias
Чисто технически - можно, в bootstrap.js домены задаются длинной строчкой, начинающейся с "const glmask =" и дальше обрабатываются регэкспами.
Чисто практически - ненужно. Это расширение - это несколько полифиллов (CustomElements, PerformanceObserver,  Element.prototype.toggleAttribute, Array.prototype.flat, Array.prototype.flatMap. Не все из этих полифиллов нужны в PM - некоторые для SeaMonkey) + вроде(?) стиль для гитлаб + патч csp (к примеру, на гитхабе разрешены скрипты только из определенных источников, и браузер пользователя к ним не относится. Патч это решает).
Просто это удобное расширение, которое можно посоветовать любому пользователю, которое "просто работает" и имеет активную поддержку автора.
Такого же результата можно достигнуть скормив эти полифиллы гризиманки как обычные userjs, а csp по необходимости обходить при помощи расширения Scriplet Doctor.
Собственно, я уже кидал в тему пару полифиллов, работающих по такому принципу. Разве что там ограничены сайты на которых они запускаются  - чтобы не самые легкие скрипты не жрали ресурсы там где они не нужны. Но если надо запустить скрипт на всех страницах - это простое "@include  * " и "@exclude  {сайт-где-ненадо-запускать}" (подробнее)
 
StupidUser
Установите Web Streams Polyfill по аналогии как описано в этом посте в разделе "установка скриптов"
Потом откройте about:config, создать -> строку, имя "general.useragent.override.ozon.ru", значение "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:68.0) Gecko/20100101 Firefox/68.0"

Всего записей: 166 | Зарегистр. 13-01-2020 | Отправлено: 22:50 23-11-2021 | Исправлено: Enobarbous, 23:34 23-11-2021
RandyOrton



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
StupidUser
Версия для печати, Ctrl-F, polyfill


----------
Гомосексуальность не является психическим расстройством.

Всего записей: 3425 | Зарегистр. 21-05-2010 | Отправлено: 22:57 23-11-2021
Enobarbous



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
RandyOrton
Жестокий вы
 
StupidUser
Но вообще - если вы не знаете что такое юзерагент и для чего он используется в браузере - вам точно нужен PM? Смена ua это почти регулярное деяние при использовании этого браузера (даже последние страницы темы не дадут соврать) - и еще не самое костыльное...
Не то чтобы я вас отговаривал конечно

Всего записей: 166 | Зарегистр. 13-01-2020 | Отправлено: 23:04 23-11-2021 | Исправлено: Enobarbous, 23:19 23-11-2021
Fedor_Sumkin

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
может хватит возмущаться тем, что "злой-подлый-гадкий-гугол" отламывает поддержку 4х- и более летних браузеров, особенно с учетом того что это можно решить одним префом? Это уже реально смешно, особенно с учетом того, что мы, как пользователи, по-сути занимаемся некрофилией со всеми этими древнефоксоклонами.
Извиняюсь, конечно, но надоело уже...

Неплохая попытка, Гугел, но нет
Форум с обновляшками на два блока вниз
 
Добавлено:
Если бы всё решалось одним префом, я бы с Presto не уходил.  
А с таким развитием, интернет превратится в тикток ленту вперемешку с новостями кто с кем подрался, продался, чпокается или обосрался и рекламу всего необходимого под это дело со ссылками на магазины. Гигабайты памяти и кучи ядер в никуда, автообновляшки и bleeding edge в наличии.
Впадать в крайности и компилировать под себя браузеры с дополнениями я не хочу, но когда твой рабочий браузер внезапно оказывается недостаточно хорош и тебе наглухо отрубают значимые сервисы, например, когда это гитхабы или гуглосервисы, и встаёт работа...
Это действительно надоело
Вспоминается популярный фильм 2505 года, получивший Оскара за лучший сценарий.

Всего записей: 28 | Зарегистр. 20-11-2021 | Отправлено: 23:36 23-11-2021 | Исправлено: Fedor_Sumkin, 23:41 23-11-2021
StupidUser



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Портабельный MyPal запускается из 7zip sfx архива, так что никакие дополнения не установить (Greasemonkey требует перезагрузки). Соответственно Ozon.ru остается при следующем запуске не рабочим. Это можно как-нибудь победить? Есть где-нибудь уже распакованный портабельный MyPal?

Всего записей: 494 | Зарегистр. 19-04-2003 | Отправлено: 01:37 24-11-2021
freed7



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Grishanenko
Цитата:
заблокировать возможность открытия новых вкладок
Откройте конфиг, наберите tab / newtab / tabnew и прошерстите все параметры, возможно есть который отвечает за запрет открытия новых вкладок.

Всего записей: 98 | Зарегистр. 30-10-2020 | Отправлено: 01:39 24-11-2021
RandyOrton



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
StupidUser
Распакуйте архив и запускайте.

----------
Гомосексуальность не является психическим расстройством.

Всего записей: 3425 | Зарегистр. 21-05-2010 | Отправлено: 01:55 24-11-2021
DimitriusXZ

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
По умолчанию Pale Moon для Windows XP сейчас работает с YouTube?
Или что-то еще нужно ставить?

Всего записей: 723 | Зарегистр. 17-01-2010 | Отправлено: 06:48 25-11-2021 | Исправлено: DimitriusXZ, 07:01 25-11-2021
RandyOrton



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
DimitriusXZ
Работает.

----------
Гомосексуальность не является психическим расстройством.

Всего записей: 3425 | Зарегистр. 21-05-2010 | Отправлено: 07:00 25-11-2021
DimitriusXZ

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
У меня не открывается просмотр видио.
Пишет обновите браузер.
Что можно сделать?

Всего записей: 723 | Зарегистр. 17-01-2010 | Отправлено: 19:33 25-11-2021
grey_rat

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Стыдоба какая https://habr.com/ru/company/habr/blog/590111/#comment_23749143
Хабр на лисах фактически не тестируется, про ESR ветку там вообще не в курсе. Смотрят как сайт открывается на двух последних версиях FF.
Ща я им там напишу по этому поводу .....

Всего записей: 1112 | Зарегистр. 20-01-2015 | Отправлено: 19:40 25-11-2021
RandyOrton



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
У меня не открывается просмотр видио.
Пишет обновите браузер.  

Может вы для начала версию браузера озвучите?

----------
Гомосексуальность не является психическим расстройством.

Всего записей: 3425 | Зарегистр. 21-05-2010 | Отправлено: 20:20 25-11-2021
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171

Компьютерный форум Ru.Board » Компьютеры » Программы » Pale Moon (часть 3)


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru

Рейтинг.ru