Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Операционные системы » UNIX » Выбор дистрибутива GNU/Linux’а

Модерирует : ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75

Открыть новую тему     Написать ответ в эту тему

KEM



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Выбор дистрибутива ГНУ/Линукса
под ваши специфические нужды

 

Неполный перечень топиков по дистрибутивам см. в «Путеводителе по форуму».

 
 
Q: У меня 64-разрядный процессор. Дистрибутив, скомпилированный под какую архитектуру, устанавливать: amd64[1] или x86[2]? Некоторые рекомендуют ставить x86, почему? А если у меня более 4 Гб оперативной памяти?
A: По идее, надо всегда использовать бинарники, скомпилированные под вашу процессорную архитектуру — теоретически это позволяет использовать все возможности процессора, добиваясь наилучшей производительности. Это так, однако на персональной машине (не на сервере) увеличение производительности заметно, скорее всего, не будет.  
Основные проблемы, которые подстерегают вас при использовании не x86, исходят от производителей проприетарного софта, которые не выпускают свои продукты под другие архитектуры. Если установка прикладного 32-разрядного софта на 64-разрядную систему не представляет особых трудностей, а использование 32-разрядных библиотек, например адоубовского флэш-плэйера3, возможна через враппер, то с драйверами на некоторые устройства значительно сложнее. Следует узнать, требуются ли вам драйвера, имеющие только x86-версии.
Вполне возможна установка 32-битной системы на 64-разрядное ядро, но этот вариант чреват конфликтами и в общем случае не оправдан.
Даже если у вас более 4 Гб памяти (оперативной плюс своп), то суровой необходимости использовать 64-разрядную систему все равно не появляется — достаточно установить Линукс, собранный с поддержкой PAE4, отдельные процессы, правда, все равно не смогут использовать более 4 Гб памяти.
 
Q: Какое окружение рабочего стола (DE): GNOME, KDE, xfce и др. выбрать для персонального компьютера?
A: Выбор между Гномом и КДЕ стоит делать исключительно на свой вкус, попробовав и то, и другое.
Xfce позиционируется как более «легкая», менее требовательная к ресурсам, среда, однако некоторые предпочитают ее и при достатке ресурсов.
Lxde — как еще более легкая.
Браузер, офисный пакет и специализированный софт вы, наверняка, выберете независимо от DE.
 
Q: Я хочу использовать ГНУ/Линукс для таких-то целей. Есть ли для этого нужный софт?
A: Вам в тему «Программы под ГНУ/Линукс».
 

1) На всякий случай напоминаем, что «i» и «amd» — указание на разработчиков архитектур, а не на производителя экземпляра процессора.
2) «x86» — в данном случае обобщенное название интеловских 32-разрядных архитектур: от i386 до i686.
3) Кстати, amd64-версия флэш-плэйера разрабатывается и уже вполне пригодна к использованию.
4) К примеру, в Дебиане пакет с PAE-Линуксом называется linux-image-686-bigmem, в Убунте — linux-generic-pae, кстати, при установке Убунта выберет нужное ядро сама.


Первый пост темы имел вид...

Всего записей: 387 | Зарегистр. 02-09-2004 | Отправлено: 18:31 02-11-2008 | Исправлено: ASE_DAG, 15:23 08-12-2014
Valery_Sh



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Romul81
 
Смысл проверять поведение DE на вируталке? Всё рано ведь не будет полной картины.
 
Cinnamon нормально работает на реальном железе, в том числе и с масштабированием всё ОК. Разве что сам чего  нарукоблудил по популярным советам в нетях.

Всего записей: 1968 | Зарегистр. 30-06-2008 | Отправлено: 16:13 21-12-2018
Romul81



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Valery_Sh
 
ОК. Убедили. На днях поставлю на железо и протестирую. В частности этот момент с масштабированием Qt-программ. Может и полюбится этот Cinnamon

Всего записей: 1280 | Зарегистр. 03-03-2008 | Отправлено: 16:36 21-12-2018
Valery_Sh



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Romul81
 
Не "убеждал" ни разу .... Просто интересовался: в чём смысл? По мне, это как оценивать тачку по её симуляции на тренажёре (или в игрушке)

Всего записей: 1968 | Зарегистр. 30-06-2008 | Отправлено: 19:54 21-12-2018
Romul81



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Valery_Sh

Цитата:
По мне, это как оценивать тачку по её симуляции на тренажёре (или в игрушке)

Теоретически да. На на практике, в моём случае я вполне могу выделить под виртуалку ядер так 8 для процессора (с полной нагрузкой) и 16-24ГБ памяти. В сочетании с активированными в БИОСе технологиями виртуализации и SSD это позволяет системе вполне бодро шуршать. Единственный затык - это с видео. А на нём да, висят технологии рендеринга DE. Cinnamon, к примеру, честно предупреждает, что работает в Software-mode.

Всего записей: 1280 | Зарегистр. 03-03-2008 | Отправлено: 20:07 21-12-2018
Valery_Sh



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Romul81
Так ведь встречают по одёжке... По крайней мере большинство первый раз выбирающих дистр. По комфорту для глаз в первую очередь. (у кого глаза не очень, тот поймёт)
 
Кстати, здесь или в смежной ветке N лет тому уже был холивар по схожей тематике. И наверняка не первый. Можно  пошукать поиском.

Всего записей: 1968 | Зарегистр. 30-06-2008 | Отправлено: 17:06 22-12-2018
Romul81



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Valery_Sh

Цитата:
Кстати, здесь или в смежной ветке N лет тому уже был холивар по схожей тематике. И наверняка не первый. Можно  пошукать поиском.

Я, как новичок, идеологически пока не "закостенел", поэтому ни к какому лагерю пока не принадлежу Ни в плане дистра, ни DE. Что касается старой инфы, то в контексте Линукса к ней нужно подходить очень осторожно. Инфа годичной давности может оказаться абсолютно неверной на данный момент. Неизменным пока остаётся баг KDE/Nvidia  
Вы правильно говорите - нужно смотреть самому, и, желательно, "в живую".
 
Я пока на временной Manjaro/Netrunner в виртулках допиливаю свой арчик, с нужными мне пакетами. Этот дистр относительно легко собирается с практически всеми основными DE. Пока делаю под Budgie. Как допилю, буду пробовать устанавливать его наживую, как и другие, уже собранные дистры с разными DE. Там и станет окончательно ясно, что для меня лучше на конкретном железе. В плане DE - дистрибутив-то практически тот же. Этим будет достигнута чистота эксперимента :-D
 
Буду держать, по возможности, в курсе дела своих изысканий.

Всего записей: 1280 | Зарегистр. 03-03-2008 | Отправлено: 19:21 22-12-2018 | Исправлено: Romul81, 19:23 22-12-2018
Romul81



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Mavropontis (10:49 21-12-2018)
Цитата:
на Cinnamon меню было вполне читабельно.

 
Valery_Sh (14:13 21-12-2018)
Цитата:
Cinnamon нормально работает на реальном железе, в том числе и с масштабированием всё ОК.

 
Всё-таки мои подозрения оказались небезосновательными - пост на reddit.com

Цитата:
I can tell you that using Mint 19 (Cinnamon) scaling just works. I still ended up increasing the font scaling in System Settings -> Fonts to make it a little bit bigger. It propagates across all Cinnamon apps.
 
Note that Qt and Gnome apps will not follow this behavior, they don't run scaled and are unusable. For Qt apps, I had to use an environment variable, e.g., create a launcher script "QT_SCALE_FACTOR=2 someapp", it's annoying but fixes the problem 100%. For GTK, supposedly there's a GDK_SCALE=2 variable, but it did nothing when I tried it with the 2 Gnome apps I had. Gnome being Gnome, means Gnome apps are all broken. I think you'll have this issue on every single environment.

Всего записей: 1280 | Зарегистр. 03-03-2008 | Отправлено: 19:40 23-12-2018
Romul81



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Madwatcher (Пост)

Цитата:
Да, наверное придется колупаться в логах. Боже, но как не хочется! Тут другой работы по горло, и думаешь отбрыкаться с малыми затратами. Типа прилетит вдруг волшебник. Или выпустят обновление. Но вообще странно, мир-то большой. Не я один это Lubuntu поставил. Все остальное работает.  
А нет, вот еще засада, интеловский фортран отказался вставать на 18.04. Но те проблему знают, обещали поправить в следующей версии. Вообще меня убивает современный подход, когда из-за рисования какой-то сраной кнопочки не работает солидное математическое ядро. Представляете, космонавты на Землю вернуться не могут, потому что в меню выбор "Приземление" глючит, студент на Qt постарался.

 
Попробуйте установить Lubuntu способом, описанным здесь. Я ставил именно так с Budgie DE. Как я уже говорил, проблем с GD никаких.
Только после этого станет окончательно ясно, в чём заключается проблема.

Всего записей: 1280 | Зарегистр. 03-03-2008 | Отправлено: 19:27 21-02-2019
allin0



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Я не знаю может я не в ту тему попал.
 
1. Есть UBUNTU Studio, как его подсоединить в сети?
2. Как поставить еще один язык на клаву?
 
Или проще поставить 18.04?
 
Спасибо.

Всего записей: 24 | Зарегистр. 09-09-2006 | Отправлено: 01:17 01-03-2019
Engaged Clown



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
delete

----------
Опросы ru-board'а

Всего записей: 8589 | Зарегистр. 08-06-2006 | Отправлено: 16:16 15-03-2019 | Исправлено: Engaged Clown, 01:01 14-09-2019
bredonosec



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
посоветовали на попробовать на старом ноуте (i3, 4G ram, - satellite L300-1AM) lubuntu. Но в виде сборок с софтом. Если что такое лубунта и где её в сети взять, я еще соображу, то что за сборки, и как их отличать, и какие обходить стороной, и вообще, что там может быть нужно не входящее в дистр стандартно, - не имею представления. Разумеется, не единственной, а второй системой.  
Использование планируется простенькое - пошариться в сети, попилить какие-нибудь фото, соорудить некоего юзера без прав, чтоб серфинг был свободным, но ничего нельзя было поломать, скачав какую-нибудь пакость, или нажав что не то (у бывшей дамы видел подобное когда-то, впечатлился),  
Плюс, возможно, немного поиграться с доставшимися свитчами и сиськами на тему конфигурирования и посмотреть, как оно будет реагировать.. Словом, потренироваться на кошках.  
 
собсно вопрос, что за зверь эти "сборки", нужно ли оно мне вообще?  
И, тут проскакивала мысль про "современные дистрибутивы" - а если взять некий устаревший? Или тогда с репозитария оно ничего не сможет взять под моё железо? Или там вообще ничего не скачивается в процессе установки, всё локально как в винде?

Всего записей: 15906 | Зарегистр. 13-02-2003 | Отправлено: 13:24 19-09-2019
Denisjuk



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
bredonosec

Цитата:
собсно вопрос, что за зверь эти "сборки", нужно ли оно мне вообще?

сборки делают на основе оригинала, типа система с каким-то набором софта типа чтобы все было искаропки (некоторый софт неопытному пользователю будет сложновато установить самостоятельно).
какие обходить стороной вы уж сами решайте тем более что большинство сборок можно запустить в режиме live-dvd чтобы все опробовать без установки на жесткий диск.

Цитата:
Или там вообще ничего не скачивается в процессе установки, всё локально как в винде?  

вообще то там если галочку не поставить то и скачивать ничего в процессе установки не будет


----------
Лучше переспать, чем недоесть!

Всего записей: 3411 | Зарегистр. 03-02-2003 | Отправлено: 13:34 19-09-2019
gryu



дикий гусь
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
bredonosec

Цитата:
lubuntu. Но в виде сборок с софтом. Если что такое лубунта и где её в сети взять, я еще соображу, то что за сборки, и как их отличать, и какие обходить стороной, и вообще, что там может быть нужно не входящее в дистр стандартно, - не имею представления.
Ну во первых, Lubunta это уже сборка.  
Есть дистрибутив Ubuntu. Это ТАК СКАЗАТЬ первоисточник. На его базе различные более или менее ответственные товарищи лепят различные сборки с прицелом на конкретного пользователя.  
Почему "ТАК СКАЗАТЬ", Ubuntu это тоже не первоисточник..., но  для простого пользователя именно так и будем считать.
 
Так что "в общем и целом вам посоветовали поставить сборку с софтом от Васисуалия Пупкина", если переводить на виндовый язык.
У означенного Васисуалия есть версии Лайт, есть Фулл. Вот и смотрите что вам надо.
Но как правило в любой "лайт" версии уже есть всё что нужно для знакомства.
 
Почему Лубунта? Ну эти сборки позиционируются как "для слабого железа".  
Однако имея платформу (i3, 4G ram, - satellite L300-1AM)* вам любая пойдет. Железо у вас не "слабое".
 
* -  я бы хотел уточнить. У вас там именн i3 или штатный T3200? На платформу i3 ставится, поэтому и вопрос.  
 
 
Добавлено:

Цитата:
И, тут проскакивала мысль про "современные дистрибутивы" - а если взять некий устаревший? Или тогда с репозитария оно ничего не сможет взять под моё железо? Или там вообще ничего не скачивается в процессе установки, всё локально как в винде?  
Смотреть степень поддержки и тогда всё скачается, если надо.  
Это тоже как в Винде (почти).  
Если поддержка есть, то нет проблем. А "для ХР и 98" сейчас "из репозитария МС" не качается.. ;-(
Однако с *NIX-подобными системами всё сложнее и проще.
Из исходников всегда (почти всегда) можно скомпилить и поставить практически всё под практически любую устаревшую версию ОС.  
При этом поскольку не один вы такой, а сообщество *NIX обладает более широкой душой чем сообщество Win, то и самому компилить не факт что придётся. Полазил по форумам и или подробную инструкцию нашёл или вообще готовое.  
 

Всего записей: 12751 | Зарегистр. 15-03-2006 | Отправлено: 14:07 19-09-2019 | Исправлено: gryu, 14:21 19-09-2019
bredonosec



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
или штатный T3200

да, он, пардон, что ввел в заблуждение.  

Цитата:
У означенного Васисуалия есть версии Лайт, есть Фулл. Вот и смотрите что вам надо.
Но как правило в любой "лайт" версии уже есть всё что нужно для знакомства.  

в смысле, лубунта лайт - и лубунта фулл -это и есть названия версий, которые стоит глядеть? (для меня просто это всё если не китайская, то как минимум французская грамота. Же не манж па сис жур произнести смогу, но даже со словарем не говорю))
 

Цитата:
вам любая пойдет. Железо у вас не "слабое".
ну, я рассуждаю по логике "лишних свистоперделок не надо, абы графический интерфейс был (после общения с ddrescue консоли никсовой побаиваюсь), и минимальный набор софта для жизни
 

Цитата:
Смотреть степень поддержки и тогда всё скачается, если надо.  

учитывая, что я не знаю, где искать, этот процесс у меня, чую, затянется на время, за которое железо устареет морально )) Лучше подскажите, если была некая версия, после которой резко потяжелело, и если не было такого в недавние года, то, наверно, проще взять современую?  
И кстати, после установки пересобрать можно? Или это надо будет что-то лепить в исошни, инсталлировать с нуля и т.д.? Или оно не даст полезного выхлопа (оптимизации прожорливости), если после полной установки и начала пользования?

Всего записей: 15906 | Зарегистр. 13-02-2003 | Отправлено: 15:41 19-09-2019
Valery_Sh



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
bredonosec
Нету никаких лубунту лайт и фулл. И вообще, это будет боль и слёзы. Хрустальный шар вещует, что "тестеры на виртуалках" насоветовали.
 
Ставьте нормально сразу.
http://releases.ubuntu.com/18.04/
 
А можно и Минт. Он привычней для неофита.  
https://linuxmint.com/edition.php?id=267
Под капотом у ней внутре неонка у неё та же убунта лтс.
На i3 и 4 ГБ поедет, тем более, что особых требований и нетуть.

Всего записей: 1968 | Зарегистр. 30-06-2008 | Отправлено: 18:19 19-09-2019 | Исправлено: Valery_Sh, 18:45 19-09-2019
gryu



дикий гусь
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
лубунта лайт - и лубунта фулл -это и есть названия версий, которые стоит глядеть?  
Нет.  Это я образно. Просто смотреть подборку дистрибутива.
В остальном я пожалуй соглашусь с чуть выше выступившем товарищем.  
Ставьте Linux Mint с оболочкой Mate. Лучшеб наверно с Cinnamon или даже XFCe, но вам сложнее будет освоится.
19-ю не ставьте. Что о она на мой взгляд "излишне инновационна".  
 
Так. Возможно вы в курсе, но...  
В *-nix системах OS это одно, а пользовательская оболочка это другое.  
Оболочки можно ставить отдельно и переключатся при желании.  
Как правило, разницы в дистрибутивах с разными оболочками практически нет. Просто кому какой шелл удобней.    
 

Цитата:
учитывая, что я не знаю, где искать, этот процесс у меня, чую, затянется на время, за которое железо устареет морально ))
Открываете WiKi и смотрите сроки поддержки версий  "базового" дистрибутива.  
В вашем случае мы решили что э то Ubuntu. (версии  LTS, что значит "долгосрочная поддержка")
Затем идёте на сайт "сборки" и смотрите на какой версии она сделана.  
Всё сразу ясно становится.
Цитата:
Лучше подскажите, если была некая версия, после которой резко потяжелело, и если не было такого в недавние года, то, наверно, проще взять современую?
Вот 19-й Минт и не берите. Т.е. 18-ю убунту вам брать нестоит. Работать будет и не плохо, но с напрягом.
Цитата:
И кстати, после установки пересобрать можно? Или это надо будет что-то лепить в исошни, инсталлировать с нуля и т.д.?
Можно. Пишите в поисковике "Linux Mint обновление" и всё понятно.  

Цитата:
Или оно не даст полезного выхлопа (оптимизации прожорливости), если после полной установки и начала пользования?
Линь это не винда. Тут конечно "хвосты" тоже тянутся и если вы "ушатали систему", то обновление не поможет, но от того что вы попользуетесь 17 минтом, а потом апните его до 18-го хуже небудет.  
 
Добавлено:
Valery_Sh

Цитата:
На i3 и 4 ГБ поедет,
Я уточнил это вопрос и bredonosec ответил. Не i3 у него, а T3200. Это Core 2 Duo.  
 


----------
-Мы не договаривались торговать сёстрами своих королев! (с)
Жизнь, это тот промежуток вечности, который человек должен пройти сам. Не опираясь на костыли религий или церквей.

Всего записей: 12751 | Зарегистр. 15-03-2006 | Отправлено: 20:16 19-09-2019 | Исправлено: gryu, 20:46 19-09-2019
Valery_Sh



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Ага, тупанул я, прозевал уточнение про ЦеПе.
 
Ну, на Т4500 (Т4600? забыл уже...) и старшем  в линейке чипсетном видео, 18-й Минт/цинамон работал приемлемо.
Тут вообще важнее видео и ssd, пусть даже простенький,  чем голый проц одного примерно времени.
Не на всяком чипсетном видео будет радовать... ssd в моём старом буке вообще стоял древний V300 на SF и профит от него был очччень заметен.

Всего записей: 1968 | Зарегистр. 30-06-2008 | Отправлено: 20:51 19-09-2019
gryu



дикий гусь
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
P.S.
Гм.  
Сейчас глянул.  
18.3 версия Linux Mint (Sylvia) на основе Ubuntu 16.04.3 LTS.  
Срок поддержки Ubuntu 16.04.3 LTS - Февраль 2018.
Однако это вас может не беспокоить.  Работает и поддерживается всё по прежнему.  
 
Добавлено:
Valery_Sh
У меня 17 Mint по сей день на Lenovo T40 стоит и нормально работает. а это вообще P4M ..  
С дровами под АТИшную видяху помучатся пришлось, но пашет.  
Но это не суть.  
Я собссно потому и предполагал Cinnamon или даже XFCe, что видяха не самая быстрая.  
Mate он красивый и как следствие обжорный....  
Intel GMA 4500MHD у него интеграшка.  
 
Добавлено:
Intel GMA 4500MHD у него интеграшка.  

Шото глянул я эту видяху по поиску в контексте "она + Linux"

Решения есть, но "из коробки" драйверов под неё нету.  
Местами упоминается что решения от 2010-2012 годов уже вроде как не работают. (репозитарии поменялись)
Мдя...  
bredonosec, короче пробуйте.  
"высокопроизводительной графики" у вас полюбому нет, а совместимый драйвер от Mint вроде ее поддерживает. Ну и **** с ним! Вам же для ознакомления и 3D графику крутить вам врятли надо будет.

Всего записей: 12751 | Зарегистр. 15-03-2006 | Отправлено: 20:52 19-09-2019 | Исправлено: gryu, 21:19 19-09-2019
Garrett

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Если комп слабый, то лучше ставить 19-й Mint XFCe. Очень даже ничего.

Всего записей: 2602 | Зарегистр. 16-10-2003 | Отправлено: 21:33 19-09-2019
iNNOKENTIY21



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Что нужно, какой дистр, что бы грузится с флешки, но при этом сохранять внесенные в систему изменения, раздел на хдд, или… возможно такое? Мне мало одного сеанса.

Всего записей: 2719 | Зарегистр. 16-08-2012 | Отправлено: 22:06 19-09-2019
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75

Компьютерный форум Ru.Board » Операционные системы » UNIX » Выбор дистрибутива GNU/Linux’а


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru