Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Операционные системы » UNIX » Выбор дистрибутива GNU/Linux’а

Модерирует : ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86

Открыть новую тему     Написать ответ в эту тему

KEM



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Выбор дистрибутива ГНУ/Линукса
под ваши специфические нужды

 

Неполный перечень топиков по дистрибутивам см. в «Путеводителе по форуму».

 
 
Q: У меня 64-разрядный процессор. Дистрибутив, скомпилированный под какую архитектуру, устанавливать: amd64[1] или x86[2]? Некоторые рекомендуют ставить x86, почему? А если у меня более 4 Гб оперативной памяти?
A: По идее, надо всегда использовать бинарники, скомпилированные под вашу процессорную архитектуру — теоретически это позволяет использовать все возможности процессора, добиваясь наилучшей производительности. Это так, однако на персональной машине (не на сервере) увеличение производительности заметно, скорее всего, не будет.  
Основные проблемы, которые подстерегают вас при использовании не x86, исходят от производителей проприетарного софта, которые не выпускают свои продукты под другие архитектуры. Если установка прикладного 32-разрядного софта на 64-разрядную систему не представляет особых трудностей, а использование 32-разрядных библиотек, например адоубовского флэш-плэйера3, возможна через враппер, то с драйверами на некоторые устройства значительно сложнее. Следует узнать, требуются ли вам драйвера, имеющие только x86-версии.
Вполне возможна установка 32-битной системы на 64-разрядное ядро, но этот вариант чреват конфликтами и в общем случае не оправдан.
Даже если у вас более 4 Гб памяти (оперативной плюс своп), то суровой необходимости использовать 64-разрядную систему все равно не появляется — достаточно установить Линукс, собранный с поддержкой PAE4, отдельные процессы, правда, все равно не смогут использовать более 4 Гб памяти.
 
Q: Какое окружение рабочего стола (DE): GNOME, KDE, xfce и др. выбрать для персонального компьютера?
A: Выбор между Гномом и КДЕ стоит делать исключительно на свой вкус, попробовав и то, и другое.
Xfce позиционируется как более «легкая», менее требовательная к ресурсам, среда, однако некоторые предпочитают ее и при достатке ресурсов.
Lxde — как еще более легкая.
Браузер, офисный пакет и специализированный софт вы, наверняка, выберете независимо от DE.
 
Q: Я хочу использовать ГНУ/Линукс для таких-то целей. Есть ли для этого нужный софт?
A: Вам в тему «Программы под ГНУ/Линукс».
 

1) На всякий случай напоминаем, что «i» и «amd» — указание на разработчиков архитектур, а не на производителя экземпляра процессора.
2) «x86» — в данном случае обобщенное название интеловских 32-разрядных архитектур: от i386 до i686.
3) Кстати, amd64-версия флэш-плэйера разрабатывается и уже вполне пригодна к использованию.
4) К примеру, в Дебиане пакет с PAE-Линуксом называется linux-image-686-bigmem, в Убунте — linux-generic-pae, кстати, при установке Убунта выберет нужное ядро сама.


Первый пост темы имел вид...

Всего записей: 388 | Зарегистр. 02-09-2004 | Отправлено: 18:31 02-11-2008 | Исправлено: ASE_DAG, 15:23 08-12-2014
Alukardd



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ASE_DAG
И то верно) Я даже на ссылки не посмотрел) Зато whois домена глянуть не забыл Что за привычки у меня...

----------
Microsoft gives you windows, linuх gives you the whole house...
I've been using Vim for about 4 years now, mostly because I can't figure out how to exit it.

Всего записей: 6468 | Зарегистр. 28-08-2008 | Отправлено: 08:54 21-12-2012
Maza777



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
а ну Линуксоиды, насоветуйте мне хороший дистрибутивчик Ubuntu для офисного использования. Года два назад немного юзал Ubuntu 10, ниче такая был. Сейчас скачал Ubuntu 12.10, жуть какая тяжелая, поставил на ноут где Win XP летала просто, Убунта жутко тормозит, винт разрывается, такое не устраивает. К тому же там Юнити интерфейс вообще странный, Гном на 10 версии намного больше нравился. И хочется типа "комплекта" чтоб бы в дистрибутиве стоял уже wine и прочие полезные утилиты, для работы с документами, VNC какой нибудь и тому подобное, то есть проверенную сборку.  
Два дня посидел настраивая 12.10, только Wine минут 30 ставился. Может какая есть 10 версия уже укомплектованная и проверенная ? Ставить кучу таких прог на каждый комп в ручном режиме жутко неудобно. тем более на 12 версию прийдется на каждой машине Гном накатывать еще.
основное требование быстродействие, т.к. половина компов из серии 2006-2007 времен P4

Всего записей: 739 | Зарегистр. 20-11-2007 | Отправлено: 17:41 26-02-2013 | Исправлено: Maza777, 17:46 26-02-2013
dgm



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Maza777
Не могу отнести себя к спецам, но после перебора поставил Ubuntu 12.04 LTS, полет нормальный (но на 10 было веселее). 5 лет поддержки с апреля 2012 для офиса не помешает.

Всего записей: 316 | Зарегистр. 18-11-2003 | Отправлено: 18:49 26-02-2013
temp776

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Существует ли такое чудо: что-нибудь полегче Ubuntu (желательно без граф. наворотов а-ля compiz) с поддержкой Steam for Linux?

Всего записей: 27 | Зарегистр. 10-09-2012 | Отправлено: 19:38 26-02-2013
adasiko



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
temp776
Ну так не одной оболочкой Ubuntu же, вот Xubuntu например поставить 12.04 32 битную версию
Steam должен пойти

Всего записей: 1807 | Зарегистр. 30-06-2008 | Отправлено: 20:12 26-02-2013 | Исправлено: adasiko, 20:14 26-02-2013
Maza777



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
может кто то подсказать большая ли разница между Ubuntu 10.04.4 LTS и Ubuntu 12.04.2 LTS. Использоваться будет для не новых офисных ПК, 10-ка просто намного веселее работает и интерфейс изначально приятнее Gnome все таки. понимаю что 12 убунта новее и поддержка наверно лучше, но мне как новичку хочется что то обкатанное и проверенное, но может я чето то про 10 релиз не знаю ,может там уязвимости или какие другие глюки есть, которые сделает установку 12 более разумной.
 
сейчас же для  10 тоже наверно еще выходят обновление, да и нужны ли они, если все будет работать и так то обновления вообще не нужны. Вон Win XP сейчас везде в офисе стоит и не обновляется сколько лет уже и работает же.

Всего записей: 739 | Зарегистр. 20-11-2007 | Отправлено: 00:42 01-03-2013 | Исправлено: Maza777, 00:52 01-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Maza777
Цитата:
и интерфейс изначально приятнее Gnome все таки.

На Ubuntu 12.04 можно тоже установить Gnome, что я, кстати, и сделал:

Код:
sudo apt-get install gnome-panel

или

Код:
sudo apt-get install gnome-shell

 
Разницу с 10.04 не знаю, никогда версией 10.04 не пользовался

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 00:58 01-03-2013 | Исправлено: jummp, 01:01 01-03-2013
5

Редактировать | Цитировать | Сообщить модератору
Есть ноутбук Intel Celeron M 1.3 ГГц, 1гб оперативной памяти.
Хочу поставить не него последний Ubuntu 12.10, что скажете, будет нормально работать или подтормаживать?

Отправлено: 11:16 16-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
5,
я бы установил Gnome Classic DE... думаю, что с Unity будет подтормаживать с такой конфигурацией железа.

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 11:25 16-03-2013
5

Редактировать | Цитировать | Сообщить модератору
jummp
А сейчас разве есть дистрибутивы с Gnome Classic?

Отправлено: 12:14 16-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
5, есть, конечно...  Но Gnome Classic можно установить и на стандартную Ubuntu (Unity) -
Код:
sudo apt-get install gnome-panel

Но вообще я предпочитаю LTS versions.  К тому же на старых видео-картах Unity Interface (12.10) может и не загрузиться.  В версии 12.04 LTS - помимо Unity, есть еще и Unity 2D, который не требует video-accelerator...

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 12:47 16-03-2013
5

Редактировать | Цитировать | Сообщить модератору
jummp
Ubuntu 12.10 и Lubuntu 12.10 не устанавливаются:
 
This kernel requires the following features not present on the CPU:
pae
Unable to boot - pleace use a kernel appropriate for your CPU.
 
Может Debian встанет?

Отправлено: 14:37 16-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
5, во всех версиях 12.10 - более новая версия Linux Kernel (точно не помню, но по-моему 3.8), очевидно, этот Linux Kernel не совместим с Вашим железом. Пробуйте Ubuntu 12.04.2.  Если снова та же ошибка, пробуйте 12.04.1.  В новой Debian - тоже по-моему новый Linux Kernel (если не ошибаюсь).

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 15:27 16-03-2013
goletsa



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
5

Цитата:
 
This kernel requires the following features not present on the CPU:  
pae  
Unable to boot - pleace use a kernel appropriate for your CPU.  

Используйте ядро без PAE, в чем проблема то? Качаете install dvd 12.04, там должен быть выбор ядра при запуске.

Цитата:
Может Debian встанет?

Возможно.
jummp

Цитата:
В новой Debian - тоже по-моему новый Linux Kernel (если не ошибаюсь).  

Дело не в версии ядра а в том с какими опциями оно собрано.
В expert режиме я думаю можно без проблем поставиться.
 
Добавлено:
5

Цитата:
Есть ноутбук Intel Celeron M 1.3 ГГц, 1гб оперативной памяти.  
Хочу поставить не него последний Ubuntu 12.10, что скажете, будет нормально работать или подтормаживать?

Я бы поставил Xubuntu 12.04 LTS.
Не так прожорлива к памяти как гном.
 
 
Добавлено:

Цитата:
 Пробуйте Ubuntu 12.04.2.  Если снова та же ошибка, пробуйте 12.04.1.  

Смысл? Там только минорные патчи ядра. Багфиксы и только.
Установленная 12.04 просто обновляется с интернета до последней (12.04.2 на данный момент).

Всего записей: 5786 | Зарегистр. 21-06-2005 | Отправлено: 15:32 16-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
5, нашел информацию - будто Debian 6 - с Linux Kernel 2.6.  Согласен с goletsa - пробуйте DVD Ubuntu 12.04 - я сам устанавливал с дистро DVD.  
 

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 15:43 16-03-2013
goletsa



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Кстати проверил, при выключенной галочке PAE в виртуалбоксе установщик xubuntu-alternate нормально стартанул. Версия 12.04.2
 
 
Добавлено:
jummp

Цитата:
будто Debian 6 - с Linux Kernel 2.6.

Дело не в версии ядра.
Вот такое не запустится:
http://packages.debian.org/squeeze-backports/linux-image-2.6-686-bigmem
А такое запустится:
http://packages.debian.org/squeeze-backports/linux-image-2.6-686
Все разница в опциях.
Версия самого ядра при этом 3.2+46~bpo60+1
 
Добавлено:
Погуглил, убунтовцы жгут и в 12.10 выпилили из репозиторие no-pae ядра.

Всего записей: 5786 | Зарегистр. 21-06-2005 | Отправлено: 15:43 16-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
goletsa
Цитата:
Я бы поставил Xubuntu 12.04 LTS.
Не так прожорлива к памяти как гном.  

Я как-то пробовал XFCE - да, памяти берет меньше, но интерфейс не понравился...  Конечно, дело вкуса, но я удалил этот Desktop, скудный какой-то.

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 15:48 16-03-2013
goletsa



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
jummp
Тот же GTK и довольно неплохо кастомизируем.
Хотя дело вкуса, я как-то больше за минимализм.
http://d.pr/i/vH6n
 

Всего записей: 5786 | Зарегистр. 21-06-2005 | Отправлено: 15:55 16-03-2013
jummp

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
goletsa, ну да - если кастомизировать его, то у Вас на картинке неплохо смотрится.  А я как только установил xfce - даже не понял что это было - сразу же и удалил это недоразумение...

Всего записей: 190 | Зарегистр. 31-08-2010 | Отправлено: 16:00 16-03-2013
goletsa



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
jummp
На самом деле минимум изменений. Убрал родную нижнюю и добавил кнопок в верхнюю панель.
Кнопки снизу это одно из расширений компиза, показывает запущенные приложения, закос на док в макоси.
Вот тот же гном шел мне показался очень странным, вроде выглядит просто но чтото поменять сложно.
 
Добавлено:
Правда это в debian, что там напихали в Xubuntu по умолчанию мне сложно сказать, давно последний раз видел в живую.

Всего записей: 5786 | Зарегистр. 21-06-2005 | Отправлено: 16:04 16-03-2013
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86

Компьютерный форум Ru.Board » Операционные системы » UNIX » Выбор дистрибутива GNU/Linux’а


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru