Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Операционные системы » UNIX » Linux Mint! RuNew

Модерирует : ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14

Открыть новую тему     Написать ответ в эту тему

SyCraft



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Cборка дистрибутива Linux Mint

 

 
Дистрибутив GNU/Linux, основанный на Ubuntu. Содержит:
 
* Adobe Flash плагин для браузеров,
* Sun Java,
* unrar,
* RealPlayer,
* Мультимедиа кодеки,
* Поддержку воспроизведения DVD,
* Проприетарные драйвера для видеокарт.
 
Также содержит оригинальные программы, такие как
mintAssistant, mintInstall, mintUpdate, mintBackup, mintDesktop, mintConfig и другие.
 
Оффсайт оригинала: https://linuxmint.com/
 
Зеркала на Yandex
 
Сборки Linux Mint
 
Скачать Торренты

Всего записей: 618 | Зарегистр. 09-03-2005 | Отправлено: 10:23 15-05-2009 | Исправлено: Engaged Clown, 10:25 28-08-2017
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
poman1983, отсюда, напрямую инсталлировать пакет Ubuntu или Debian, не пробовали:
qtwebengine5-dev
libqt5webengine5?

Всего записей: 2539 | Зарегистр. 09-12-2005 | Отправлено: 09:51 24-11-2018
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
poman1983

Цитата:
начинает ругатся  на версии

Вполне естественно в этом случае, там 5.4.1, а у вас 5.5.1. Вы уверены, что обновиться до Linux Mint 19 - не вариант? Или что-то из предыдущих версий Dream DRM Receiver заюзать? Так понял, там и Qt4 когда-то использовали... Может, есть какой-то PPA или GetDeb какой с Dream DRM Receiver? Сам не гуглил, но, может быть, где-то обсуждались варианты решения - дискусии на SF.net, разные Ubuntu- и оноло-Ubuntu-форумы?
 
Если кругом "нет", то, видимо, придётся собрать libqt5webengine5 самостоятельно: детали/инструкции здесь, из того PPA вам понадобятся файлы
qtwebengine-opensource-src_5.4.1+3~xenial-0ubuntu1.dsc
qtwebengine-opensource-src_5.4.1+3~xenial-0ubuntu1.debian.tar.gz
qtwebengine-opensource-src_5.4.1+3~xenial.orig.tar.xz
Версию есть смысл сменить на ту, что используется для библиотек Qt5 у вас или сократить до чего-то типа "5.5.1+dfsg-0ubuntu1".
Исходники qtwebengine в их репозитории, вам понадобится qtwebengine-5.5.1.tar.gz.
 
P.S. В файлах на странице Dream DRM Receiver на SF.net есть бинарники для Ubuntu'образных версии 18.04, а это значит, что вполне возможно, что версия Qt5 5.5.1 может оказаться староватой и не уметь то, что умеют 5.9.х и выше: можно попробовать посмотреть в исходниках Dream DRM Receiver (в реадми, файлах проекта(ов) и т.п.), нет ли там требований к минимальной версии Qt5.
P.P.S. Не знаю, кому как, но лично мне не очень нравится держать в системе, использующей систему пакетов, ведро компиляторов, сред, dev-пакетов и т.п. для сравнительно нечастых задач, поэтому в виртуалке стоит та же версия ОСи (сейчас Xubuntu 18.04 x64), почищенная от обычного софта, - там подобное и проворачиваю.
 
Добавлено:
Ещё варианты: попробовать поискать файлы версии 5.5.1 в других дистрибутивах (Arch или RPM-based) или попробовать вытащить отсюда https://download.qt.io/archive/qt/5.5/5.5.1/ (я с телефона, слить и расковыривать 600-метровый qt-opensource-linux-x86-5.5.1.run не вариант).
 
nauticus
Linux Mint 18.x собирают на Ubuntu 16.04 LTS, вылезет та же проблема с зависимостями, а имеющийся там rpm-файл с 5.5.1 только х32.

Всего записей: 5973 | Зарегистр. 28-01-2008 | Отправлено: 10:08 24-11-2018
poman1983

Junior Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Мои познания в Linux  заставляют меня  долго изучить предложенные рекомендации))
наконец поюзать  18.3 в виртуалке . или обновится до 19.
 
Ну официальные инструкции вроде сдесь :
https://drm.sourceforge.io/wiki/index.php/Main_Page
https://sourceforge.net/p/drm/wiki/Build%20on%20Ubuntu/
 
ну естественно ничего не ставится  и не компелируется из за отсутствия  вышеназванных библиотек.  
 
 
Linux Mint 18.x собирают на Ubuntu 16.04 LTS, вылезет та же проблема с зависимостями, а имеющийся там rpm-файл с 5.5.1 только х32
ОНИ и вылазят ))

Всего записей: 41 | Зарегистр. 12-08-2006 | Отправлено: 10:43 24-11-2018 | Исправлено: poman1983, 10:49 24-11-2018
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
poman1983
В общем, начали не с того конца: поддержку сборки с Qt4 и Qt5.5 дропнули в ревизии r1018. Проще всего использовать что-то из предыдущих версий или обновиться до Linux Mint 19.
 
Попробуйте так:

Код:
sudo apt-get install qt5-default libqt5webkit5-dev libqt5svg5-dev libqwt-qt5-dev
sudo apt-get install libpulse-dev libhamlib-dev fftw3-dev libpcap-dev libsndfile-dev libfaad-dev
svn checkout -r 1017 svn://svn.code.sf.net/p/drm/code/dream dream-1017
cd dream-1017
qmake
make
sudo cp dream /usr/local/bin/dream

и не обновляйте, пока не переберётесь на Linux Mint 19.

Всего записей: 5973 | Зарегистр. 28-01-2008 | Отправлено: 14:45 25-11-2018
poman1983

Junior Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Не удачно.   Ругается все на те же  QT
 
/usr/bin/ld: cannot find -lQt5OpenGL
collect2: error: ld returned 1 exit status
Makefile:848: ошибка выполнения рецепта для цели «dream»
make: *** [dream] Ошибка 1

Всего записей: 41 | Зарегистр. 12-08-2006 | Отправлено: 05:43 26-11-2018
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Похоже, требуется ещё и libqt5opengl5-dev, есть в репозитории.

Всего записей: 5973 | Зарегистр. 28-01-2008 | Отправлено: 08:26 26-11-2018
poman1983

Junior Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Пакеты, имеющие неудовлетворённые зависимости:
 libqt5opengl5-dev : Зависит: libqt5opengl5 (= 5.5.1+dfsg-16ubuntu7.5) но 5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1 будет установлен
                     Зависит: qtbase5-dev (= 5.5.1+dfsg-16ubuntu7.5)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
 
 
в репозитории не лазил, все лишние отключено там.
 
Еще варианты установить это прогу на эту ОС ?

Всего записей: 41 | Зарегистр. 12-08-2006 | Отправлено: 09:10 26-11-2018 | Исправлено: poman1983, 09:15 26-11-2018
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
poman1983
Что-то у вас там не то с пакетами, похоже, подключен PPA с KDE-backports, пакеты с которого странно "дружат" с оф. репозиторием.
 
Собрал ревизию r1017, х64.

Всего записей: 5973 | Зарегистр. 28-01-2008 | Отправлено: 14:34 26-11-2018
poman1983

Junior Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
А вот за эту спасибо,  запустилась.

Всего записей: 41 | Зарегистр. 12-08-2006 | Отправлено: 06:55 27-11-2018
SPY



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Имеется Linux Mint 19 (Cinnamon edition), хочется на нем запустить Chrome Remote Desktop. Все делалсь по мануалу от гугла, однако после установки и настройки были только проблемы: либо ошибка входа в систему 'Could not acquire name on session bus', либо зависания машины намертво. Нормального подключения не удалось добиться, пришлось удалить. Есть рабочие способы запустить Chrome Remote Desktop на Mint 19?

Всего записей: 629 | Зарегистр. 07-11-2003 | Отправлено: 14:49 13-12-2018 | Исправлено: SPY, 14:49 13-12-2018
Engaged Clown



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Linux Mint 19.1
17-12-2018
 
http://www.opennet.ru/opennews/art.shtml?num=49813

----------
Опросы ru-board'а

Всего записей: 8589 | Зарегистр. 08-06-2006 | Отправлено: 22:24 19-12-2018 | Исправлено: Engaged Clown, 10:19 20-12-2018
ULer



Moderator
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Прошу подсказать, как побороть ошибку при запуске некоторых flash-игр в броузере?

Код:
Context3D not available! Possible reasons: wrong wmode or missing device support.

LinuxMint 19.1 x64, Cinnamon, Mozilla Firefox.

----------
http://dc.ru-board.com/ — Anime, Books, Cartoons, Clips, Databases and Maps, Games, Misc, Music, Movies, Scripts and Templates, Series, Soft, Training Courses, XXX.

Всего записей: 6667 | Зарегистр. 18-10-2007 | Отправлено: 20:55 08-01-2019
ig1967

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Linux mint 19 Xfce при выключение ноутбука делает щелчок,что это ?

Всего записей: 10 | Зарегистр. 09-11-2018 | Отправлено: 12:35 29-01-2019
ULer



Moderator
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Почему на чистой системе Linux Mint 19.1 Cinnamon x64 может не запускаться Project Libre?

----------
http://dc.ru-board.com/ — Anime, Books, Cartoons, Clips, Databases and Maps, Games, Misc, Music, Movies, Scripts and Templates, Series, Soft, Training Courses, XXX.

Всего записей: 6667 | Зарегистр. 18-10-2007 | Отправлено: 12:33 31-01-2019
nemip



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Приветствую всех!
Подскажите, кто в теме, как сделать так, чтобы в Минте курсор устанавливался на кнопке по умолчанию, как в Винде. Очень не хватает этого, особенно при скачивании картинок - нужно либо целиться мышкой каждый раз в кнопку "Сохранить", либо бросать мышь и жать "Enter".

Всего записей: 45 | Зарегистр. 18-03-2013 | Отправлено: 20:32 19-03-2019
gryu



дикий гусь
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
nemip

Цитата:
как сделать так, чтобы в Минте курсор устанавливался на кнопке по умолчанию, как в Винде. Очень не хватает этого, особенно при скачивании картинок - нужно либо целиться мышкой каждый раз в кнопку "Сохранить", либо бросать мышь и жать "Enter".
 
А можно как то более развёрнуто вопрос?  
Что то я по поводу Винды не понял. Что значит "бросать мышь" и вообще. .. Куда курсор на какой такой "кнопке по умолчании" должен устанавливаться?  

Всего записей: 12744 | Зарегистр. 15-03-2006 | Отправлено: 21:19 21-03-2019
legionpheonix



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Доброго вечера все форумчанам.
Подскажите существует ли пакет sssd для linux mint?
Чтобы можно быстро установить через менеджера, а не консоль и запустить пк в домен в интерфейсе без конфигурирования конфиг-файлов?

Всего записей: 258 | Зарегистр. 23-02-2012 | Отправлено: 18:53 10-04-2019
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
legionpheonix
Linux Mint сделан на основе Ubuntu, пакет sssd есть в оф. репозитории.

Всего записей: 5973 | Зарегистр. 28-01-2008 | Отправлено: 20:05 10-04-2019 | Исправлено: Skif_off, 20:06 10-04-2019
legionpheonix



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Skif_off
Спасибо большое!
 
Добавлено:
Ещё один вопросик остался.
Linux Mint дружит нормально с крипто про?
Достаточно будет по этой инструкции установить?
https://www.cryptopro.ru/faq/kak-ustanovit-csp-na-debianubuntu

Всего записей: 258 | Зарегистр. 23-02-2012 | Отправлено: 21:08 10-04-2019
legionpheonix



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Кто-нибудь пробовал делать ярлык конкультанта плюс в минте? Шара на винде по сети.

Всего записей: 258 | Зарегистр. 23-02-2012 | Отправлено: 10:04 18-04-2019 | Исправлено: legionpheonix, 10:04 18-04-2019
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14

Компьютерный форум Ru.Board » Операционные системы » UNIX » Linux Mint! RuNew


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru