Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Операционные системы » UNIX » Ubuntu

Модерирует : ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188

Открыть новую тему     Написать ответ в эту тему

ShriEkeR



Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Предыдущие части ветки: [#2] [#1]



Актуальные версии (список версий Ubuntu|Википедия):
Ubuntu 19.10 (Eoan Ermine) — выйдет 17 октября 2019, поддержка до июля 2020,
Ubuntu 19.04 (Disco Dingo) — поддержка до января 2020,
Ubuntu 18.10 (Cosmic Cuttlefish) — поддержка до июля 2019,
Ubuntu 18.04.2 LTS* (Bionic Beaver) — поддержка до апреля 2023,
Ubuntu 16.04.6 LTS* (Xenial Xerus) — поддержка до 21 апреля 2021,
Ubuntu 14.04.6 LTS* (Trusty Tahr) — поддержка до апреля 2019
   *LTS — a long term support version, выпуск с длительной поддержкой

Установочные образы с другие набором предустановленного ПО:
Kubuntu (KDE), Ubuntu GNOME (Гном без Юнити), Xubuntu (Xfce)
Lubuntu (LXDE), Ubuntu MATE (MATE)
Alternative (Альтернативный установщик Ubuntu при проблемах с графикой), и прочие...

Русское сообщество: Wiki, ubuntu.ru, Популярный русскоязычный форум
Англоязычные ресурсы: omgubuntu.co.uk, ubuntuguide.org, ubuntuforums.org
Журнал об Ubuntu: Full Circle Magazine

Чтобы получить русифицированную систему сразу после установки, настройте доступ в интернет перед установкой
Шпаргалка по командам в Ubuntu-образных дистрибутивах
Не удается обновить стандартной процедурой (Update Manager) неактуальный релиз

Ubuntu — это по большей части свободная операционная система, основанная на Debian GNU/Linux, с регулярным выпуском новых релизов (через каждые полгода), ориентацией на пользователя и удобство использования (это должно просто работать™), а также с поддержкой обновлений системы безопасности каждого релиза в течение 18 месяцев после выпуска. Ubuntu поставляется с последним релизом (стабильной версией) Gnome и с такой подборкой программного обеспечения для сервера и рабочей станции, которая позволяет создать удобное рабочее окружение с помощью лишь одного установочного DVD.
 
Обращение Марка Шаттлворта к пользователям.

Всего записей: 6382 | Зарегистр. 27-09-2004 | Отправлено: 18:43 03-05-2011 | Исправлено: NoAngel777, 05:50 21-06-2019
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
 Вот все открылось -RTL8192EU  

Ну и отлично. Введите в терминале
uname -r
В результате вы получите используемую версию ядра (например, linux-4.9.0-15-amd64 - это у меня), далее нужно пробовать скомпилировать ядро (включить свой драйвер в ядро) на вашей Ubuntu 20.04, по методике, описанной здесь, на askubuntu.
По крайней мере, на 18 убунту эти дрова вставали. Возможно, что встанет и на ваше 5.4, кто знает.
Делаете так:

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 20:35 19-03-2021 | Исправлено: nauticus, 20:58 19-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
споткнулась на второй строчке
failed to connect to githab.com port 443: connection timed out

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 09:53 20-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
споткнулась на второй строчке

Все нормально со скачиванием пакета во второй строчке, только что попробовал у себя:

Все скачивает и ошибки нет.
Chumaric, проблемы с сетью? Брандмауэр включен, может быть? Хотя может быть и GitHub (откуда скачивается пакет) в то время подвис. Всяко бывает.
Пробуйте еще раз и продолжайте идти по инструкции.  
 
Добавлено:
Chumaric, на своем Debian c ядром 4.9.0-15 прошел полностью установку вашего драйвера (как виндузятники говорят) или как в Linux говорят:компилировал модуль Wi-Fi адаптера  на чипе RTL8192EU в ядро.
 
Все установилось, смотрите сам процесс на картинках, картинки кликабельны до полноразмера, вот продолжение установки после того, что на первой картинке выше:

Единственное, что было написано:  
"Kernel preparation unnecessary for this kernel.  Skipping..." - Подготовка ядра не нужна для этого ядра. Пропуск...
Но это объяснимо - не так давно устанавливал дрова для своего Wi-Fi адаптера, там процедура подготовки ядра уже была.
Так что данная метода с askubuntu  для MERCUSYS MW 300 UM на чипе RTL8192EU и на моем ядре 4.9 в Debian 9  вполне себе работает. Проверить не могу - такого адаптера у меня нет, но компиляция прошла успешно, без ошибок, поэтому ваш Wi-Fi адаптер  должен у меня заработать.
Но повторюсь - будет ли работать на вашем ядре, вероятно, что ядром 5.4 - неизвестно. Нужно пробовать.

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 11:56 20-03-2021 | Исправлено: nauticus, 12:43 20-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ядро 5.8.0-45 вторая попытка-  
failed to connect to githab.com port 443: connection timed out
 
Добавлено:
если просто ткнуть на ссылку мышью, легко открывается

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 15:20 20-03-2021
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Chumaric
Вв правда не замечаете, что у вас в ссылке опечатка?

Всего записей: 6222 | Зарегистр. 28-01-2008 | Отправлено: 15:40 20-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Chumaric, что-то либо вы делаете не так, либо что-то не так с системой. Либо у вас нет сети, кто его знает?
Установил специально в виртуалке Xubuntu 20.04 Xfce , Ubuntu Pack от ualinux, т.е. та же Ubuntu Xfce, но немного допиленная. Ядро 5.8.0-45:

Вторая строка, скачивание с гитхаба без проблем и ошибок:

Далее:

Последнее:

Как здесь, на последней картинке видно, ошибка произошла лишь на последней стадии компиляции ядра.
 
Как и предполагалось - на ядро 5.8 модуль вашего WI-FI не встал.  
 
Вариатов 2 - либо искать более свежий модуль для чипа RTL8192EU, чтобы его воткнуть в 5-е ядро ubuntu 20.04, либо установить систему версии ниже 18.04.3, где уже 5-е ядро. Т.е. версию Ubuntu не позднее 18.04.2, там  версия ядра Linux - 4.18. Такая же версия ядра используется в Ubuntu 18.10.
ps Chumaric, cоветую попробовать установить Ubuntu*Pack Xfce (Xubuntu) 18.04 от ualinux
Основные изменения OEM Pack в отличие от оригинального дистрибутива:
Можете посмотреть здесь:Ubuntu OEMPack 18.04 - все рабочие столы от них же, от ualinux.
Ну или установить оригинальную Ubuntu 18 (что хуже и неудобнее, на мой вгляд - много телодвижений после установки) и компилировать ядро по методике выше. Ведь на своем Debian c ядром 4.9.0-15 я же установил ваш драйвер.

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 15:56 20-03-2021 | Исправлено: nauticus, 16:00 20-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Skif off, о какой опечатке вы говорите?

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 19:27 20-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Chumaric, вот ещё один вариант установки - RTL8192EU Wireless Adapter on Void Linux.  
И посмотрите ещё здесь и здесь: RTL8192EU in *buntu?
Как про ваш адаптер-то: Бесноватый USB Wireless RTL8192EU
ps здесь дана ссылка на deb пакет:dkms_rtl8192eu_4.3.1.1.11320.20140505_all.deb
Пробуйте, Chumaric, пробуйте все варианты. С экзотическим оборудованием и редкими чипами в Linux скорее всего именно так - мы не ищем легких путей.
Но ради справедливости нужно признать, что такое бывает крайне редко.

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 19:33 20-03-2021 | Исправлено: nauticus, 19:57 20-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
медленно, но дошел до четвертой строчки-(bad exit status: 2)
ERROR (dkms apport): binary package for rtl8192eu: 1.0 not found
Error! bad return status for module build on kernel: 5.8.0-45-generic (x86-64)
consult /var/lib/dkms/rtl8192eu/1.0/build/make.log............
а в кубунте с ядром 4.... все четыре строчки завершились хорошо
 
Добавлено:
да, все как и у вас, но не понял, что значит искать более свежий модуль?

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 20:23 20-03-2021 | Исправлено: Chumaric, 20:26 20-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
что значит искать более свежий модуль

По всем ссылкам модуль чипсета  RTL8192EU (иначе, проще и понятнее, по виндовому - дрова, интегрируемые в ядро, чтобы ядро увидело этот WI-FI адаптер) в основном 3-х летней давности. Создан этот модуль в то время под ядро именно 4.ххх (поэтому я на Debian 9 c ядром версии 4.9.0-15  и установил его успешно, без ошибок вообще).  
Ибо 5-го ядра тогда в природе не существовала. Отсюда и проблемы с компиляцией ядра с этим модулем на версиях Linux c версией ядра 5.ххх. Поэтому и стоит поискать, вдруг есть модуль именно под ядро 5.ххх.
Либо установить Ubuntu версии ниже 18.04.3, где уже 5-е ядро.  

Цитата:
а в кубунте с ядром 4.... все четыре строчки завершились хорошо

Так и должно быть на ядре 4.ххх, подтвержение верности рассуждений выше
Добавлено:
Chumaric, deb пакет dkms_rtl8192eu_4.3.1.1.11320.20140505_all.deb  не пробовали установить?

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 20:49 20-03-2021 | Исправлено: nauticus, 20:56 20-03-2021
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Chumaric

Цитата:
Skif off, о какой опечатке вы говорите?

Вот про это:

Цитата:
failed to connect to githab.com port 443: connection timed out

Или это была не копипаста из терминала?
 
Возможно, есть смысл проверить ядро посвежее, вдруг добавили? https://kernel.ubuntu.com/~kernel-ppa/mainline/
 
В выхлопе строка

Код:
consult /var/lib/dkms/rtl8192eu/1.0/build/make.log.

там нет подсказки? Там может быть что-то тривиальное...
 
Добавлено:
Стоило взглянуть родную репу https://github.com/Mange/rtl8192eu-linux-driver
Судя по коммитам, добавлены фиксы для сборки с 5.х.
 
Добавлено:
Ещё есть PPA, оказывается: https://launchpad.net/~kelebek333/+archive/ubuntu/kablosuz

Всего записей: 6222 | Зарегистр. 28-01-2008 | Отправлено: 04:44 21-03-2021 | Исправлено: Skif_off, 04:49 21-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Стоило взглянуть родную репу

Skif_off, поясните, пожалуйста, почему вы полагаете родной репой эту?
А скажем, не эту?
В обоих случаях речь идет о rtl8192eu-linux-driver.
Интересно просто, чтобы знать на будущее, хотя сам всего лишь раз решал подобную проблему (писал об этом выше), но вдруг, пригодится.

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 11:10 21-03-2021
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
nauticus
В начале страницы есть ссылка

Цитата:
jeremyb31/rtl8192eu-linux-driver
forked from Mange/rtl8192eu-linux-driver

значит, исторически репозиторий от Mange был первым.
Исходя из ваших ссылок на инструкции, можно предположить, что активность у Mange когда-то приостановилась, поэтому jeremyb31 форкнул и подхватил/подпилил. Когда именно, что и как, честно говоря, лень уточнять, да и ни к чему, наверное, но на данный момент судя по последним коммитам репозиторий от Mange явно актуальнее форка и модуль должен собраться с ядрами 5.х.
 
P.S. Пакеты в PPA не смотрел, не знаю, из чего они собираются.
 
Добавлено:
Стало любопытно, посмотрел: в PPA пакеты собираются из https://github.com/Mange/rtl8192eu-linux-driver

Всего записей: 6222 | Зарегистр. 28-01-2008 | Отправлено: 14:46 21-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
На ядро 4.15 установил успешно. Потренировался.
Chumaric, deb пакет dkms_rtl8192eu_4.3.1.1.11320.20140505_all.deb  не пробовали установить?
Не пробовал, не могу, я на эти строчки смотрю как на волшебные руны

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 15:04 21-03-2021
Skif_off

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Chumaric
Попробуйте добавить PPA и пакет из него, остальное, по идее, система сделает сама:

Код:
sudo add-apt-repository ppa:kelebek333/kablosuz
sudo apt update
sudo apt install rtl8192eu-dkms

Всего записей: 6222 | Зарегистр. 28-01-2008 | Отправлено: 15:37 21-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
попробовал во второй строчке по ссылке вставить github.com/Mаnge , нет сказала, патч драйвер уже существует и в не пустой директории
 
Добавлено:
добавил РРА, а что дальше?
 
Добавлено:
Вот странные вещи! Оказывается эта собака видела и мой встроенный адаптер Бродком.
Увидел на Ютубе- пуск, программы,доп. драйверы- вот они оба моих вай фай устройства. Установить.
Бродком заработал! Без прописки мак-адресов и прочей лабуды.
Но ртл8192 не заработал.
 
Добавлено:
Вообще не пойму,вынимаю свисток-пропадает индикатор сети, может это ртл8192 работает??
 
Добавлено:
nauticus,  Skif off     спасибо за поддержку
 
Добавлено:
Да,заработал.

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 16:11 21-03-2021 | Исправлено: Chumaric, 16:12 21-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Вообще не пойму,вынимаю свисток-пропадает индикатор сети, может это ртл8192 работает??  

Chumaric, да, скорее всего именно так. Переключается сеть на активный сетевой адаптер.
При наличии сетевого подключения и подключения моего Wi-Fi адаптера на чипе c811 Realtek Semiconductor индикатор сети и у меня пропадал и сеть автоматом переключалась на работающий USB Wi-Fi.

Цитата:
Не пробовал, не могу, я на эти строчки смотрю как на волшебные руны

Это просто. .deb пакет устанавливается ну, по аналогии - ну именно как exe файл в Windows

Цитата:
а то, что в гугле нашел, видимо ,мне не понять никогда  


Цитата:
Да,заработал.

Chumaric, рад за вас. Я же говорил, что не боги горшки обжигают.
Пожалуйста, отпишитесь после проверки работоспособности обоих ваших Wi-Fi, и внутреннего и USB, ок? И на какой системе заработал и какая версия ядра.
зы к слову, свой Wi-Fi адаптер , я писал об этом выше, я подключал вовсе не от необходимости, а любопытства для... У меня оптиковолокно 800 Мб/с, Wi-Fi не нужен, так что это было моё повышение квалификации

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 22:07 21-03-2021 | Исправлено: nauticus, 22:17 21-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Ноутбук старый НР пх7400 , система Ubuntu 20.04, встроенный адаптер Бродком , из под Виндуса он сам определяется и работает, а в Убунте его и не видно вообще, только в дополнительных драйверах оказался.
Сейчас заработал только наружный rtl8192, я его для этого и купил, не ожидая ничего от старого встроенного. Для проверки включил фильм, все идет, как и на проводном соединении.
Видимо, установился проприетарный третьесторонний драйвер. Интересно, я его увижу, если наберу cd rtl8192eu,,,,,,,,? (нет, не увидел, пишет, просто ртл 8192 линукс драйвер)
Для интереса можно попробовать еще раз установить Бродком, вдруг и он заработает, тогда окажется зря покупал наружный
 
 
Добавлено:
Нет, не заработает, для него драйверов не предлагается, а те, что опен сос на версии 5.8 работать не будут. Так, что покупал не зря.

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 09:45 22-03-2021 | Исправлено: Chumaric, 10:10 22-03-2021
nauticus



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
встроенный адаптер Бродком

Какой у него чип?

Всего записей: 2992 | Зарегистр. 09-12-2005 | Отправлено: 12:35 22-03-2021
Chumaric

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
BCM4311 802.11b/gWLAN Controller

Всего записей: 94 | Зарегистр. 27-10-2011 | Отправлено: 12:49 22-03-2021
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188

Компьютерный форум Ru.Board » Операционные системы » UNIX » Ubuntu


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru

Рейтинг.ru